hostnames and mpi?

Hi All: I get this when I run hostname on my two computers

box #1:

patti@OS121:~/test001> hostname

box #2:

patti@OS121-1:~/test001> hostname

I noticed that in the hostnames YaST widget, box #1 has entries for both boxes, but box #2 has no entries for either box. I believe they should both have entries for both boxes (both are connected to a switch). Should I manually enter this in YaST on box #2, ir is there some other better way to do this, such as joining a windows domain or setting up samba? The goal is to have both of these running a single job via MPI.

Thank You!!

I should have said these are two vanilla opensuse 12.1 x64 installations. I thought they should both have their own machine names in YaST/hostnames. I guess one of the machines is misconfigured and I am not sure how to fix the configuration.

This is set in the file /etc/HOSTNAME and it is normal to have .site at the end, which you can change.

To make sure of what I say, check hostname this way:

cat /etc/HOSTNAME

To Change you can do this:

su -
echo "" > /etc/HOSTNAME
hostname -F /etc/HOSTNAME

You would expect each PC to use a different hostname.

Thank You,

Fixed it - I just checked the ip address with ifconfig then made in entry in YaST/hostnames. Now my software seems to work OK (it was using localhost as well as the nonexistent host name).


Oooo - just saw this. Time to educate me! lol!

One of the computers had .site appended to the host name in YaST/hostname and the other didn’t. I think this is related to windows workgroups and therefore to smb:/ right?

It is set by default here in YaST:

It is listed as the Domain Name in YaST, while the Hostname is the only thing used by Samba in a Workgroup. I don’t know much more than that.

Thank You,