Host file manager for opensuse?

Is there a recommended host file manager for Leap? Recently I learned how to block dns by reading about this old app InterWebPPC browser - A rebrand of TenFourFox for the future - Macintosh Garden

I never knew that I could just block malicious hosts by editing my host file. I have just been using this fille to block unwanted hosts, but I found this one too GitHub - Ultimate-Hosts-Blacklist/Ultimate.Hosts.Blacklist: The Ultimate Unified Hosts file for protecting your network, computer, smartphones and Wi-Fi devices against millions of bad web sites. Protect your children and family from gaining access to bad web sites and protect your devices and pc from being infected with Malware or Ransomware. and I used it to block facebook and twitter from tracking me around.

But what I really need is an application that will let me specify who, out of know trackers that I want to block. I there a program like that for opensuse that works really good and is easy for a novice to use?

I have found that blacklisting these DNSes greatly speeds up my web browsing.

I want to install this code

But I want to be able to allow instagram sometimes.

I don’t know of an app that’s specifically written for managing the hosts file since the file format is really simple - it’s just: hostname hostname1 hostname2 hostname3

Where “” is the IP address for the hostnames. For blocking hosts, you just set it to

It is an “always on” operation, though - you either use the hosts file or you don’t; you can’t say “sometimes I want these to resolve, and sometimes I want them to not resolve”. To do that, you probably want to look at using a proxy server instead - something like Privoxy can be good to use. I run an open firmware on my router, and use an ad-blocking addon for it that applies a similar concept (it returns “not found” for blocked DNS entries).

Other approaches would be to use tools like AdBlock Pro (a browser extension) or other similar extensions in the browser. I typically deploy multiple solutions, so I don’t see a lot of ads or unwanted content - and none of them require running scripts on my systems.

1 Like

I simply misspell the entry when I want to allow, then fix it to terminate allow.

1 Like

That’s a good idea, mis-spell and re-spell. I wonder why my internet is so much faster by blocking all of those DNS’es? Chrome won’t update now. But I think I can try to locate the DNS that is getting blocked so that I can let Chrome update.

I haven’t applied the big super list to my opensuse host file, only the windows 10 hard drive has Instagram blocked. I can’t even use firefox, only edge, since something like 1,000,000 DNSes are blocked.

I was hoping to find a Yast app that would help me research the DNSes a little, and help me get some peer feedback about how these websites are acting maliciously, and then using a GUI empower me to find new great websites with a white list feature.

I am just learning about all this, so I totally understand why it would be a mistake to just install that script, when I could rather, enjoy the learning process, and examine the blacklist (it’s 750,000) entries long and examine the whitelist myself. I might try to make my own app!

If you want to block connections per host/domain better use a browser plug in like uMatrix.

1 Like

YaST > Network Service > Hostnames manages the /etc/hosts files.

But I admit that it does not do much more then you can do with any direct editing.

1 Like

I tried to install Umatrix but I can’t do anything in Chrome right now because I’m not signed in and Chrome keeps notifying me that Chrome is out of date. I am steering away from google at the moment so I might just strop using Chrome all together for a while on Opensuse. I will try Chromium. I have a Pixel book, that I love, it’s like a chrome-book on sterroids that I can try Umatrix on later.

Okay, I got Chromium installed and I am trying Umatrix out. Thankyou! Now I don’t have to enable a blocked DNS just to update my browser.

1 Like

Youtube doesn’t play on Chromium, maybe I blocked the DNS or something, but it plays on Chrome.

Youtube is fine on chromium here. Have you followed the multimedia guide for installing codecs?

I’ll note that I have “chromium-ffmpeg-extra” and “chromium-plugin-widevinecdm” installed here.

1 Like

Same for me but, there’s this Baeldung article on blocking specific host names by means of suitable entries pointing to the loopback IPV4 address in the ‘/etc/hosts’ file – <>

1 Like

But this method (using an entry in /etc/hosts to provide a false IP address for certain host/domain names) to block all users of the system to use that host depends on dumb users.

It is only the name resolution that fails, not the connection. Users will still be able to connect using the correct IP address

1 Like

@earthnicsi Hi, why no just run a Pihole or Adguard instance on your network. I use Pihole here on a RPi3, if need to add a block, just run pihole -b <>.


Thanks for all the great suggestions! I installed the codecs for Chromium, but still won’t play youtube videos. I must have blocked, but somehow chrome gets around it.

Why are my browsers so much faster when I the the blacklist in my hosts file?

@earthnicsi That all depends on what DNS servers your connecting to as provided by your router… Order of the /etc/nsswitch.conf hosts: line entry. The actual route to where ever your connecting.

1 Like

Because you’re limiting outbound connection attempts by preventing address lookups from succeeding.

Blocking won’t prevent Youtube from working - something else is going on there. You’ll probably want to start a separate topic on that issue - that’s very likely not a DNS/name resolution issue.

1 Like