horendous speed difference

Hi There,

I have a desktop pc with opensuse 11 connecting via a 100Mbit ethernet network to my router and i have a notebook running ubuntu 8.10 connecting with 802.11g to the same router’s wifi portion. The notebook has around 3.5Mbps downstream and 500kbps upstream and I never ever get that fast on my desktop. I’m wondering why, I used to have eth0 and vbox0 connected over a bridge br0 to the physical network in order to get virtual box connected directly to my network. I thought this was the problem and deleted br0. It seemed to be a little better in establishing connections (e.g. to the smtp server - had problems sending emails before) but the speed is still very low…Any ideas what I could check would be appreciated. Settings in yast look all good to me and ifconfig looks good too:

eth0      Link encap:Ethernet  HWaddr 00:1C:25:03:B0:F3
          inet addr:192.168.0.234  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:576  Metric:1
          RX packets:115938 errors:0 dropped:0 overruns:0 frame:0
          TX packets:85981 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:58275285 (55.5 Mb)  TX bytes:12424210 (11.8 Mb)
          Memory:effc0000-effe0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1717 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1717 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:75523 (73.7 Kb)  TX bytes:75523 (73.7 Kb)

Help would be greatly appreciated! Thanks!

I just ruled out the possibility of a hardware failure as well as i booted into my parallel native Windows for the 3rd time ever :open_mouth: (too basd there’s no puke icon ;)) to check the speed there and I got 3.5Mbps as well… >:(

And now again, it won’t let me send messages with Kontact because it wouldn’t conect to the smtp server…I even deleted the configuration in yast and re createsd it but this did not help either…Any clues are greatly appreciated!

And your sure there are no SMTP issues with your laptop or in using windows?

What does Yast identify you eth0 device as?

according to your MAC I find:

00-1C-25 (hex) Hon Hai Precision Ind. Co.,Ltd.
001C25 (base 16) Hon Hai Precision Ind. Co.,Ltd.
66,Chung Shan Rd.Tu-Cheng
Taipei Hsien 236
TAIWAN, REPUBLIC OF CHINA

Yast only says
Gigabit ethernet network
and the kernel driver loaded is e1000e. I don’t knoe if this applies or what…also i don’t think it’s that cause at my old location i didn’thave problems like that…

Hmm, your Ethernet interface MTU is 576. Normally it’s 1500 for Ethernet. How did that happen? Did you fiddle with anything in that area?

Using a lower MTU would force communication to fragment packets, with performance loss.

MTU? Uh no, I wouldn’t even know what it is with out looking it up… How can I get it back to what it’s supposed to be?
Thanks,
Ron

Under YaST > Network Devices > Network Setup, somewhere in the interface specific options.

Yup, thanks…figure it out in the mean time and set it to 1500 but unfortunately i don’t seem to be getting any speed advantage out of it :(… man…
any other ideas around? :o

Have you
Yast, Network Devices, Network Settings, Global Options: Disable “Enable IPV6” and reboot.

know what, the mtu setting seems to have re-established the speed when i’m downloading something but it’s weird, something is still messed up,
#1 smtp doesn’t send emails
#2 pages like facebook or idiomag aren’t loading at all or just partly
#3 nfs doesn’t seem to work properly either
… i don’t know man… is there maybe the wrong driver loaded or something?
Thank you for further tips and suggestions!
Ron

What’s your LAN setup like? Home LAN with broadband router? Did the router set the MTU on your workstation to 576 automatically? Are you using PPPoE on your workstation or something like that, where the MTU has to be set lower, probably something like 1492 or 1454? Have you been told by your ISP to use a particular figure? Hard to say anything meaningful without know what your LAN configuration looks like.

Standard hiome LAN
DSLrouter <-> 3com router - 3 clients two laptops connection wirelessly running ubuntu and my workstation running OS 11.0.
in router config i couldn’t find anything.
I just booted my workstation with the ubuntu 8.10 CD and it got an mtu of 576 too. Isn’t that weird? There’s no MTU setting in my router config interface…

Why do you have a 3com router between your DSL router and workstations? Is it acting as a switch or do you have multiple segments you need to connect? Or is it the wireless AP, that is you have a non-combined DSL modem and router? What is giving out addresses by DHCP? The DHCP offer can change the MTU of a client.

The DSL router is dhcp-ing 192.168.1.2 to my 3com router and my 3com router is dhcp-ing my clients in the 192.168.0.XXX range

So do you really need the 3com router, other than the fact that it is providing wireless (is it?)?

Sounds like you need to examine the config in the 3com router to see whether it’s specifying a MTU of 576 and if so why?

Oh I forgot to tell you that I have another client hanging on there, my lil file/web/ftp server. I totally missed that one before… sorry, its network config looks like this:

server:~ # ifconfig
eth1      Link encap:Ethernet  HWaddr 00:09:6B:D8:41:93
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::209:6bff:fed8:4193/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26412880 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32842424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:803862558 (766.6 Mb)  TX bytes:2360488027 (2251.1 Mb)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:213 errors:0 dropped:0 overruns:0 frame:0
          TX packets:213 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14539 (14.1 Kb)  TX bytes:14539 (14.1 Kb)

server:~ #

connected to the same router (and it’s got MTU set to 1500)…

Yes, but it still sounds like your router is handing out a MTU of 576 and either your fileserver is getting discriminatory treatment or just ignoring MTU settings in DHCP. You can look at the details of the lease on your Linux machines to see what you are getting. On Ubuntu I think it should be /var/run/dhclient-eth0.lease

Well on my laptop (ubuntu too) it shows following:

lease {
  interface "eth1";
  fixed-address 192.168.0.40;
  option subnet-mask 255.255.255.0;
  option routers 192.168.0.1;
  option dhcp-lease-time 4294967295;
  option dhcp-option-overload 3;
  option dhcp-message-type 5;
  option domain-name-servers 192.168.0.1;
  option dhcp-server-identifier 192.168.0.1;
  option interface-mtu 576;
  renew never;
  rebind never;
  expire never;
}

This is the proof that my router gives out mtu 576 huh? Now… I don’t see anywhere anything to configure… :frowning: and why should it be that at all? It used to work just fine and the notebooks are connecting nicely as well… :expressionless:

Well there’s no problem with all parties using 576 as the MTU except that the performance suffers which was your original gripe. If you raise the MTU of a client and the router hasn’t been told then packets get dropped, as you have seen. So you have to figure out why the router uses a MTU of 576 and is this deliberate or it can be changed.