hoping for some freeciv crash help

Hi, just wanted to start by saying I know that this is not an opensuse issue. I have been looking for a distro to stick with for a while now. So, having bounced around a little, I have seen the same behavior on kubuntu and fedora (kde) as well. I am now using opensuse (kde) 12.3 (and am quite happy btw).

Having said that, I am hoping someone will have a good idea to try, so thanks in advance.

The problem is opensuse always crashes to the point that I have to a hard restart on my system. I have not figured out any specific thing that happens to trigger it. Sometimes it happens very early in the game, sometimes it will happen 20 minutes into it. Regardless, it ALWAYS happens; its just a matter of when.

I have tried changing the gtk settings from oxygen-gtk to raliegh. Freeciv also has its own theming which I have played around with. Neither of these things have helped. I also searched for the sdl version, but there is no version available for 12.3. I (probobly stupidly) tried to install the 12.1 version, but it did not run for some reason. I noticed in the same repo that there is an “unplayable” qt version in development (which would be great, no doubt) but, again, it is unplayable.

Anyway, I am hoping that someone will have a solution for me. It is unclear whether this is an actual bug or not. On freeciv’s website they admit that running the game on kde is not ideal. However, I have not found anything by duckduckgoing it.

Thanks again.

i started the server and client and it seems to work fine.

Hm, I just tried to reply and was having trouble, so hopefully I haven’t double posted. Anyway, here goes: A couple of things: 1. Are you running gnome? Because I am using kde. I only ask because of your tagline. 2. It ALWAYS starts fine. It crashes after running for so many minutes (sometimes more than others).

Yes i use GNOME and it seems to be a GTK based game and may play nice with GNOME

Well, I think I may have figured out WHY this is happening. I started watching freeciv on the system monitor, and basically after each in game mouse click, it raises the amount of ram that it is using. This ram does not decrease until the application is closed, so it just keeps escalating. Now, each individual increase is pretty small, but I watched it go from a starting point of about 125mb to 130mb in about 5 minutes.

Freeciv by itself doing this still shouldn’t be much of a problem, as I have 3gb of ram on my desktop (not a lot, but should be plenty). However, I realized that I am almost always listening to music while I am playing. I use Clementine, and (who knew?) Clementine increases the amount of ram being used each time it changes songs! So, similarly, it started out at about 120mb and is at 145mb at the time of this writing. Again, small, but it is adding up. Add a web browser, email, akregator, and suddenly I could see how it could freeze up my system if left unchecked.
So, my question is: for both Freeciv and Clementine, are these bugs (the fact that they are increasing in memory usage)? **

I also haven’t looked at Amarok. I will do this next to see whether it has the same behavior as Clementine.

Thanks again for any help.

Game + anything is generally a squeeze on system resources like RAM,CPU.


Funny thing – the motherboard on my desktop fried a couple of days ago. I am assuming that that the computer crashing while playing freeciv was due to this. :shame:

the game is creating crash

On Tue, 09 Jul 2013 08:06:01 +0000, zeeshanaayan07 wrote:

> the game is creating crash

Well, I guess that’s a problem, isn’t it? But if you want help, you’ll
need to post more information - like the version of openSUSE you’re
using, the desktop environment you’re using, some information about your
system, and what specifically happens when you try to use it. Launch
whatever app it is (since you have a few threads where you’ve posted
similar messages, so this is general advice) from a terminal window and
post the output here in code tags so someone can help you.

We’re not telepaths, you know. We only know what you tell us. And right
now, what you’re telling us ain’t much.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C