(Hopefully) straightforward wireless problem

I’m a casual Kubuntu user, and recently installed openSUSE 11.1 on a friend’s Compaq Presario R3000. I’m very impressed so far, but can’t quite get the wireless working. Here is the relevant info:

The wireless device is a Broadcom BCM4303 802.11b (rev 02)
The PCI vendor/product ID codes are 14e4:4301 (rev02)

I have installed the firmware by following the instructions in lwfinger’s sticky thread and on the linuxwireless.org website.

This appears to have worked, as the command ‘sudo /usr/sbin/iwlist scan’ displays the available wireless networks, including my own. The ESSID and Address are shown correctly.

I presumably just need to configure Network Manager, but I don’t know how. I’m using the Gnome UI; I have tried adding a wireless connection by clicking the icon on the taskbar but without success. I’ve entered the SSID and my WPA passkey, but it just doesn’t do anything.

The tutorials I have read all seem to stop at this point with something like “now configure the network manager”, and no further information. The hardware seems to be working, hopefully I’m just missing the final step!

Getting Your Wireless to Work - openSUSE Forums

Post #3

One additional point to consider. The 14e4:4301 device is
802.11b-only. Are you certain that the AP is set up for b or mixed b/g

Thanks for the replies; I will post the results from that diagnostic script tomorrow (I’m no longer with the computer that I’m trying to get working).

I had a play with wicd as that is what I use with Kubuntu on my own laptop. That worked better, in that it showed the available networks, but I was still not able to connect. Authentification seemed to happen, and then it got stuck waiting for an IP.

There are many threads about this type of problem so it’s quite confusing.

Apologies to lwfinger, but I don’t really understand the question. The wireless device has been successfully used with windoze XP.

I’ve now run the script - results below. I’ve tried going through the suggested solutions on Framp’s site, but I really don’t understand enough to know what is going on.

Is it possible that I’m just not using network manager correctly? At least it is now displaying the available networks - if I click on mine then it asks for the WPA passkey several times in succession before giving up. My AP is the third in the iwlist list (ESSID wfrz)

Here are the results from the script: nopaste.info - free nopaste script and service

Edit: Just to clarify, I have switched back to NetworkManager instead of Wicd.

At least the results are of nearly no value when running the script in order to check for WLAN problems and being connected via cable at the same time.

Here are the results with wired connection removed (still the same error codes):

nopaste.info - free nopaste script and service

!!! CND0330E: WLAN credential problems exist on interface wlan0
  • double check you wireless key

  • remove encryption on the router temporarily to exclude problems with encryption

  • if your router offers “mixed” WPA (WPA/WPA2) switch to WPA only or WPA2 only

  • there is a lot of traffic on channel 1, try channel 6 or 11 in your router

OK. I read through most of that paste. You don’t have b43 loaded as a module.
You really need to read up on this. Here is a great place to read. NetworkManager - Linux Wireless
Pay special attention to this page: b43 - Linux Wireless

openSUSE 11.0 and 11.1 use the following command:

  • sudo /usr/sbin/install_bcm43xx_firmware

Ok, notice in the screenshot there. If you go with the defaults for WEP, then just enter your WEP key. If you’re using WPA, then choose WPA personal and enter in the “shared key”, which is again, whatever you have for the key. Now I do recommend you click on, for WPA, “expert settings” and tick the box “use a specific WPA version” and you’ll probably want version 1. After that, it should be connect and save.

I used to work for a major communications company providing broadband technical support, usually to the field techs. I would assist in troubleshooting wireless issues, among other things. When I went to do wireless in Linux, it took me some reading and tinkering and asking questions. So don’t feel bad.


You are on the completely wrong path.

a) The correct driver is loaded (b43legacy)

b) The firmware is alreday installed, otherwise one would not even get any scan results

A slight oversight. Nothing more. It certainly does not mean I am on the wrong path. He still, needs to follow those articles, and still needs to set up NetworkManager as directed. I find it easier to start from the begining, and ensure everything is covered.

Thanks very much for the suggestions.

  • I have triple checked the wireless key; it is definitely being entered correctly.

  • I am unable to remove encryption on the router - it is a French device (Freebox v5 - WiKi Free) that is controlled via their website. I have to choose either WEP or WPA.

  • For WPA I have three options: WPA (TKIP + AES), WPA (TKIP) or WPA (AES/CCMP). The default is the first one, which I think is the same as WPA1/WPA2. I have tried the two other options with no success.

  • I have tried channel 6 and channel 11: no success. Each time I noticed that some of the other nearby AP’s also change to the same channel - is this normal?

  • One other thing: if I run the NWData script while NetworkManager is trying to connect, I get a different error code that refers to the DHCP server. See results below:

During connection: nopaste.info - free nopaste script and service
After failed connection: nopaste.info - free nopaste script and service

My current setup is using channel 6 and WPA1(TKIP).

Although you get a DHCP error, the problem is not DHCP itself.

Association to the AP is not working, so “no IP via DHCP” is a symptom but not the “illness”.

You have a (nowadays) rare device and I don’t find any obvious error(s) in your setup.

Maybe it is a driver issue, so I suggest to try a newer driver.


Search for “compat-wireless” and read this here first:

Choosing the correct kmp-package for your installation - openSUSE Forums

Based on the second link, my system info is as follows:

Kernel version :
Kernel flavor : pae
openSUSE version : 11.1
Architecture : i586

I have found a handful of compat-wireless packages that seem to be appropriate. However, I’m not exactly sure what I am meant to do next. I tried installing one of the packages:


Is there another step? I rebooted the computer, and while I can still see the available APs, the blue wireless light is off and the radio button on the laptop has no effect. The NWData script returns these errors:

!!! CND0120E: Network card wlan0 has no IP address
!!! CND0380E: No WLANs detected on interface wlan0. Hardware and/or driver not configured properly
!!! CND0320E: WLAN turned off by hardware or software switch

I just wanted to check if I was making a basic error, or if I should try some of the other similar compat-wireless packages.

Looks like bleeding edge stuff (from 2.6.32rc with a completely rewritten rfkill-framework).

Try another package with 2.6.30.X based modules instead.

Okay, the blue light is back on. I installed:


I’m now back to the same error codes as before, although there do seem to be a few differences in the main part of the script results:

nopaste.info - free nopaste script and service

Again, Association to the AP fails, the outputs of iwlist wlan0 scan look different, but this is due to new capabilities of the drivers.

To exclude any (hopefully) issues related to NetworkManager and work on the “bare metal”, do this.

  • Create a file /tmp/wpa_supplicant.conf.

  • Get a shell, become root with su and run

rcnetwork stop #stop all networking scripts/tools

killall wpa_supplicant # just to be sure

ifconfig wlan0 up 

wpa_supplicant -Dwext -iwlan0 -dd -B -c /tmp/wpa_supplicant.conf

iwconfig wlan0

If you are associated with the AP as seen by iwconfig, then run “dhcpd” as last command, you should be online then.

Post full outputs.

I have followed the instructions but did not become associated with the AP; see results here:

nopaste.info - free nopaste script and service

I tried running the final command anyway, which wasn’t recognised. Was it meant to be “dhcpcd” instead of “dhcpd”?

Yes, I meant dhcpcd.

Wait for one of the driver gurus, I see no obvioius user/configuration errors.

You can also try to find a newer version of wpa_supplicant in OBS (use search site posted before) and repeat the procedure.

If the wpa_supplicant has been compiled with “nl80211”-extension*, you can use “-Dnl80211” instead of “-Dwext”.

 wpa_supplicant |grep -A10 drivers
  otus = Otus 802.11 WPA support interface
  wext = Linux wireless extensions (generic)
**  nl80211 = Linux nl80211/cfg80211**
  hostap = Host AP driver (Intersil Prism2/2.5/3)
  prism54 = Prism54.org driver (Intersil Prism GT/Duette/Indigo)
  madwifi = MADWIFI 802.11 support (Atheros, etc.)
  atmel = ATMEL AT76C5XXx (USB, PCMCIA)
  broadcom = Broadcom wl.o driver
  wired = Wired Ethernet driver
  ralink = Ralink Wireless Client driver
  -D = driver name (can be multiple drivers: nl80211,wext)
  -f = log output to debug file instead of stdout
  -g = global ctrl_interface
  -K = include keys (passwords, etc.) in debug output
  -t = include timestamp in debug messages
  -h = show this help text
  -L = show license (GPL and BSD)
  -p = driver parameters
  -P = PID file
  -q = decrease debugging verbosity (-qq even less)
  -u = enable DBus control interface

Okay, thanks for your help.

I tried a different version of WPA_supplicant (0.6.9-7.1) to replace the original version (0.6.4-15.13.1).

That didn’t work either, so I’ll wait for the driver gurus. I guess it might be easier to just buy a new wireless card…

I should probably change the thread title as well!