HON problem with openSUSE 12.1 KDE

Hi , i have big problem with opensuse 12.1 kde… Downloaded and installed hon (heroes of newerth) and when i launch it just wont start icon is bouncing at cursor after some time disappear but nothing happens…I already googled as much as i can but found nothing…i found similar problem with banshee but and i trayed fix but it didnt worked (to change oxygen-gtk theme for Gtk apps in KDE)… Want to use OpenSuse as primary OS but also i want to play HON on it and i dont want to switch to win or ubuntu every time i want to play …Also i have Nvidia Graphic card 8400 GS and i have 3D driver: NVIDIA 290.10 installed (as i know it is the latest driver for that card)…So anyone have any idea ?

Seems like it’s universal… I don’t know why but it seems OpenSUSE is the worst distro I tried so far. I’ve had nothing but problems with it.

I dug around the interwebs and found this:
mkdir -p “/home/$(whoami)/.Heroes of Newerth/game”; echo -e “SetSave “vid_bpp” “32”
SetSave “vid_refreshRate” “60”
SetSave “vid_resolution” “$(xrandr | grep * | cut -d’ ’ -f4 | tr x ,)”” > “/home/$(whoami)/.Heroes of Newerth/game/startup.cfg”**

copy/paste it to a konsole and it should work.