Home key not working + Ctrl-Esc key change not sticking

I’m running 11.2 RC1 on my desktop (Dell XPS 630) and my laptop (Thinkpad X200). I’m running into some strange problems.

Firstly, on both the computers, my Home key (or the Ctrl+Home combination for that matter) doesn’t seem to work. There were times that it did work, but only intermittently. Right now, as I type this, my Home key refuses to move to the front of the line. I have checked through the hotkeys and grepped through all the files in .kde4/share/config/ to see if Home is assigned to something else that might conflict, and I have found nothing. Is anyone else having this problem?

On a related note, I have the following problem on my Thinkpad Laptop, but NOT on the Dell desktop. As in Windows, I like to use the Ctrl+Esc hotkey (instead of the KDE default of Alt+F1) to open up the KMenu at the bottom left. (I know that Ctrl+Esc is normally mapped to another command by default, but I removed that hotkey association to avoid the interference.) While Ctrl+Esc has been working fine on my desktop, my laptop keeps changing the hotkey combination back to Alt+F1 after a couple of minutes, and definitely after logging into KDE. (E.g. I logged out, changed the settings directly in .kde4/share/config/kglobalshortcutsrc, and logged back in, and the setting was changed back to Alt+F1.) I have played with it for a while and hve no clue how to debug this. Any ideas/solutions?

Note that I have made numerous changes to my hotkeys, and these are the only ones I’m having problems with.

Here’s what I’ve figured out so far. My Home key now works. I had the following line in my .xmodmap to remap the X server kill combo from ctrl-alt-backspace to some other key combo involving the Pause key.

keycode 110 = Pause Terminate_Server

Turns out, ctrl-alt-backspace is now disabled by default, and running xmodmap with the line above remaps my Home key to F21 (function key 21) for some strange reason. Commenting the line above solved the problem and gave me back my Home key.

Anyhoo, now to the real bug. I can actually reproduce the other problem quite consistently, and I was wondering whether anyone else could as well. I want to open up the KMenu using some shortcut other than the default Alt+F1 (whether it be Ctrl+Esc or anything else). I tried this two ways. One way worked, and the other didn’t.

Method 1:

  1. I created a dummy user.
  2. I logged into KDE with the dummy user, giving me a fresh set of settings.
  3. Then, I went to Personal Settings (Configure Desktop) from the K Menu.
  4. I went to Keyboard & Mouse > Global Keyboard Shortcuts and selected “Plasma Workspace” from the dropbox up top that says “KDE Component”.
  5. I changed the hotkey of “Activate Application Launcher Menu Widget” from Alt+F1 to something else (you can try Shift+F2 since it’s not already assigned to something else) and hit Apply.

The Shift+F2 combo seemed to work fine. Then, when I logged out of KDE and logged back in, it reverted to Alt+F1. I tried variations on this procedure after removing the .kde* directories to get a clean set of settings. This is finally what worked.

Method 2:

Starting fresh with a new set of KDE settings,

  1. I logged into KDE.
  2. Right-clicked the Application Launcher icon at the bottom-right and clicked “Application Launcher Menu Settings”.
  3. I selected Keyboard Shortcut and changed the shortcut from Alt+F1 to Shift+F2.

Now, even after logging out and logging back in, Shift+F2 still works. Method 1 not working seems to indicate a bug. If others could verify this, perhaps it could be reported?