Home Folders Gone. EpsonCX5600 not installed. USB Drive gone

Hi everyone,

Semi-noob here. I recently installed openSUSE 11.1-Gnome2.24 on my box. Very happy with it. When I tried installing my EPSON CX5600 scanner through USB all went wrong.

  1. I was able to install epkowa driver. All cool. I then proceed to test epkowa. Epson goes through all the noises and it returns a “Successfully Tested epkowa” - ‘Test with ‘scanimage -d epkowa:libusb:005:003 -v’ succeeded’. After I click the OK button ERROR:
The scanner is not known to HAL.
To access the scanner as normal user,
udev, HAL, and hal-resmgr are needed to grant
appropriate access permissions automatically.
Therefore the scanner model must be known to HAL.
If the scanner is not known to HAL, a re-plug
of a USB scanner should help.
Otherwise a reboot should be done to restart
the whole udev/HAL/hal-resmgr machinery.
Check if the scanner is listed in the lshal output.
If a SCSI scanner which was switched on during boot
is not listed in the lshal output, the usual reason
is that the kernel module for the scanner's SCSI host
adapter does not notify HAL about the scanner device.
If even a reboot does not help, you could access
the scanner via the saned as a workaround.
For this workaround choose 'Scanning via Network'
and select the 'Local Host Configuration'.

If I try to run xsane it says no scan devices found, but if I run xsane as root (after a BIG Warning not to do so by xsane) It successfully finds the scanner and I am able to scan away. So this is only my first problem ( I do not wish to be root in order to be able to use my scanner…)

  1. Right afterwards my Home folder is no longer able to display in Nautilius. Mouse shows the timer thingy and hangs there. No response. If I try to access my files through command line I have no problem, but Nautilius is no longer able to reach my Home Folders.

  2. My external USB Fat32 Drive also stopped working at the same time as #2. When I try to mount the disk (since I can see it listed in the navigation panel of Nautilus) it throws the following error:

DBus error org.freedesktop.DBus.Error.NoReply: Did not 
receive a reply. Possible causes include: the remote 
application did not send a reply, the message bus security 
policy blocked the reply, the reply timeout expired, or the 
network connection was broken.

Can somebody please help out. I am very close to just doing a clean install again but I don’t want to go through the whole other fixes I’ve already done. Besides: It is not the way of the linux-samurai.

Oh by the way. I tried the recommendation of setting my scanner up ‘Scanning Via Network’ and it kinda works once then we’re back to ‘No Devices Found’.

Any help would be greatly appreciated!!

I’m ignorant about these two topics – but have you tried a reboot?

Yup. Several times. I’ve also gone through the Repair Tool that is included in the installation disk with no avail. I’ve done some googling on the subject and have seen that the culprit may be HAL. Te reapir tool ‘fixed’ HAL but no change.

Definitely some problem with access control… I would try updating your system first. Maybe Policykit or hal not functioning correctly. Try updating via console (as root) with:

zypper up -t package

See how that goes. Someone may be able to offer more specific advice on this.

OK. I’ve now also updated the system. ‘zypper up -t package’ did its work. I have also rebooted and still no go. Situation sticks. I have tried to run Nautilus as root as well but even as root Home folders still don’t show up…

Odd huh? Some things to check…

  1. What is the output (as regular user) of

groups

  1. Try adding another user account via yast. Then login as that user, and check home folder and scanner access.

Output for groups is as follows:

users dialout video

I have also created a new user but the new user cant get access to its home files either. Same with scanner.
I have also tried logging as root with the same results.

Any ideas???

Now that I have been rebooting a lot, I am also having problems showing the desktop files as well. Uhmm this is getting worse. Clean install getting closer n’ closer…

I remember from the dawn of times :slight_smile: smth like ‘rm -rf /var/lib/hardware/*’ . Hope this works unless you’ve already reinstalled your system. I don’t know… it’s quite strange. Can you access your files from a terminal (ctrl-F1/2/…)?

Is

rm -rf /var/lib/hardware/*

correct???

That up there looks very dangerous. Force recursive remove of all the hardware lib? How will this help?

And I do have access to my files through command.

FWIW I get: users disk dialout floppy cdrom video. Disk?

I’m not a gnome user, but I know there is a gconf-editor utility that can be used to set file permissions. Maybe your home directory permissions are screwed up.

Have look here:

openSUSE Tutorials

Enable the Advanced File Permissions Dialog in Nautilus | Tombuntu

I found this gnome tutorial. Have a look at ‘pitfalls’ section towards bottom of page. Specifically, there is some info concerning what to do if everything seems messed up for a user. I would make sure you back up any crucial data (on usb stick) before attempting anything radical though.

Good luck.

No, it’s not that dangerous. At the next boot it will just (re)discover all your hw. Search the suse db - though I’m not quite sure as I said that this would help in the end. And after all if you plan to reinstall…

Tried ‘rm -rf /var/lib/hardware/*’, it removed a lot of HAL stuff. I rebooted and the condition remains. No access to the Home Folder and scanner is a no find.
I guess I will just have to clean install it. Bummer.
But if the same problem rises again!?! I am in throwing my box out the windows…

Creating a new user helped?

Nope. I tried creating a new use and the logging in with it with no luck. Then I tried logging in as root with the same result…

What does dmesg say?

Right now, I am actually doing the clean install. I’ll let everyone in if the problem persisted after the procedure or if it was corrected. Thanks everyone for helping out.

uf…
3 hours later all is well. A clean install did the trick. I have installed Epson CX5600 correctly and am running everything all smooth.
Thanks everyone.