Hole in the head pronter problem

Believe I originall installed hp desklet d4360 with hp hplip.

Hate my self for removing driver when printer stopped responding today.

running hplip with automac settings won’t put it back now.

originally used to occasionally get weird disconnected errors when printer was really installed.

now it doesn’t work at all.

removed it through yast.

Pleas Help!!!

So, you did not give other details of your installation like openSUSE version or Desktop used as it does make a difference with the exact help we can provide. I will assume the default of KDE.

So, I would start YaST / Software / Software Management, search on hplip and elect to reinstall it if you really did uninstall it as you say.

Next, in KDE I do a Alt-F2 and enter the command: kdesu hp-setup

If the printer is networked, you have better luck entering manual mode and providing its IP address. After the printer install is complete, I seem to have better luck running Cups for printer defaults and such.

The Alt-F2 Run Command is: desktop-launch http://localhost:631/

Let me know if any of this hits home.

Thank You,

Sorry bout that. opensuse 11.1 and desktop kde.

So, I see that we still have openSUSE 11.1 repositories. Have you recently updated them and do you keep your copy of openSUSE updated? Did you attempt to following my suggestions as they do pertain to KDE, though version 11.1 is pretty old now at over 2 years old. Have you consider updating your copy of openSUSE to something newer?

Thank You,

No because when it wasn’t broke why fix it. it was working fine unfortunately i might have to now since its broken. but time is money. if it worked now i really have no desire to sit here and reinstall it. tried what you said. still not working. could using the driver outside of yast cause problems?

this is ruining my day

Suse11-Home:/home/bperrotta # hp-setup
Traceback (most recent call last):
File “/usr/bin/hp-setup”, line 45, in <module>
from base import device, utils, tui, models, module
File “/usr/share/hplip/base/device.py”, line 39, in <module>
import status
File “/usr/share/hplip/base/status.py”, line 45, in <module>
import hpmudext
ImportError: No module named hpmudext

if i load it through yast i get error: CUPSEXT could not be loaded. Please check HPLIP installation.
Suse11-Home:/home/bperrotta # hp-setup
error: CUPSEXT could not be loaded. Please check HPLIP installation.
Suse11-Home:/home/bperrotta #

Well, I can’t say about any other driver. The reason for using YaST is because the drivers were compiled for use with openSUSE. Installing an external RPM file can show up in YaST if you used it to do the install, but otherwise I can’t really answer your question properly. In the end, what you do depends on how badly you need this copy of openSUSE to work with your printer. The newer the printer, the more likely to have a problem with an older version of openSUSE and the need to install an external driver. And, of course, the better the reason to upgrade openSUSE.

Thank You,

On 11/20/2011 09:36 PM, bperrotta wrote:
> No because when it wasn’t broke why fix it.

because you miss a bunch of security updates maybe??

you might consider joining the Evergreen Project
<http6://tinyurl.com/4aflkpy> and see if you can use their repos to both
draw in some security updates and the now lost driver…

hmmmmm…the driver is probably also on the original install media…


DD http://tinyurl.com/DD-Caveat

New software isn’t always the answer. the last time i reloaded the driver it must have taken. moved to another usb port and it automatically worked. must’ve been a bad usb port. yes i love linux but im a ft pc support person and i usually only upgrade when i buy new pcs. with so many good tablets don’t even use pc much anymore but it needs to work cause tablet doesn’t have printing. my tablet runs cm7 which is linux also.

On 11/20/2011 10:56 PM, bperrotta wrote:
> im a ft pc support person

please, what is “a ft pc”?


DD