Higher resolution on dell XPS 17 (l702x)

Spent whole day googling, haven’t found solution for my problem: i just got new laptop (dell XPS 17 l702x), which is “optimus”, has integrated intel graphics + nvidia 955m graphics card. Now i can only have 1280x1024 resolution, when screen supports 1920x1080. Suse version: 12.1, KDE.
Tried just to install nvidia drivers using that “one-click install”, but after running “nvidia-xconfig”, my X server got broken, i was left only in init 3 (had to rename/delete xorg.conf file).

Tried to follow this “tutorial” - http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/469419-opensuse-12-1-optimus-laptop.html , but it didn’t work for me. (didn’t detect intel card, thrown errors like “Xlib: extension “GLX” missing on display “:0”. Error: couldn’t find RGB GLX visual”). So i gave up with that “solution”.
Then i reinstalled opensuse, tried to add resolution to xrandr, using this:

gtf 1920 1080 60
xrandr --newmode "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
xrandr --addmode VGA "1920x1080_60.00"

BUT always got error "xrandr --addmode VGA “1920x1080_60.00”, on last command i also got “xrandr: cannot find output “VGA””.

My “lspci |grep VGA” output:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 124d (rev a1)

Also tried to adjust /etc/X11/xorg.conf.d/50-device.conf, to set: Driver “vesa” (ok, i was optimist), nothing changed.

My aims: Now i just want to at least have decent resolution. Later i’m planning to plug in second monitor, use 2 monitors. I will need to install “bumblebee” for that?
Sorry, if my post doesn’t look very clear, but i still hope for any help. If solution is somewhere written - i’m sorry, then i missed it, probably. Thanks for any responses in advance. I’m adding my “cat /var/log/Xorg.0.log” output, just in case, here (it’s most of what i could have copied from konsole: SUSE Paste