High power usage of Netbook at opensuse, graphics?


I’ve installed opensuse 13.1 on my Netbook: Toshiba NB550D: http://www.notebookcheck.com/Test-Toshiba-NB550D-AMD-Fusion-Netbook.45637.0.html

The power usage is usually high ~30.5 W.
On windows it was ~17 Watt

Might be some graphics drivers be missing? The graphic-card is CPU integrated.
How to check weather the correct drivers are installed.

with regards

YaST->Hardware->Hardware Information or KInfocenter f.e.

If I see this correctly, you have an AMD Radeon HD 6250.

If you didn’t install any driver yourself you would be using the standard “radeon” driver.
You might try the proprietary fglrx driver instead, that might have better support for the powermanagement features than the radeon shipped in 13.1:

i’ve installed it, but would like to double check in terminal if its installed, command?

To check whether it’s installed, search for “fglrx” in YaST->Software Management, or run:

zypper se fglrx

(an ‘i’ in the first column means that the package is installed)

To check whether it is used and working:

Install “Mesa-demo-x” and run:

glxinfo | egrep "(render|OpenGL)"

AFAIK, fglrx comes with a program “fglrx_gears”, run this to check whether the driver is working, or run AMD’s catalyst control center (I don’t know the exact command, but you should find it in the K-Menu).

YaST and kinfocenter should show you the driver as well as already mentioned.

And you can look into /var/log/Xorg.0.log to see which driver is loaded/used and whether there are any problems.

thx, seems to work. i check the output and it seems to be installed. i’ll paste it here, but later.
The power needed is now ~10 W.

When Bluetooth is on it consumes 2 W ore - how to disable bluetooth on startup? it always on when opensuse starts

Not sure, I don’t have any system with Bluetooth.

Some thoughts:

  • try to disable it in the BIOS settings
  • disable the bluetooth service in YaST->System->Services Manager, or run “systemctl disable bluetooth.service”
  • there are bluetooth settings in KDE’s Configure Desktop as well. But I have no idea whether you can disable the hardware there.

thx, that Yast’ing worked.

opensuse runs surprisingly good on the netbook. Netbook is very practical to carry, with opensuse its even better, much less lag than on windows.