High GPU usage after KDE6 upgrade

Hello

Before the KDE6 upgrade I used X11 with Nvidia driver on an Asus laptop
I didn’t know any other way to make an external monitor work through a HDMI.

After the KDE6 upgrade (a few days ago), I had a hard time to make the GUI work. I run into several problems. One of them was the 0.1fps rendering. I am not the only one, because there are several forum topic about this problem.
Sometimes without any solution, sometimes they recommend to change the Grub or kernel modules parameters ( nvidia_drm.modeset=1)
Feedback for these recommendations are not composing.

I don’t want to change Grub or kernel module settings manually. I will if I have to.
Just I don’t understand why do I have to do it manually, and why isn’t to set up a correct settings automatic. And why is it a constant problem to setup an nvidia driver.

My current settings is KDE6, Wayland and Mesa.
Surprisingly, the external monitor works with Mesa driver. That is a progress :slight_smile:

The problem is that, there is constant 25% GPU usage.
Which (I think) significantly increases the power consumption,
but the most annoying thing is a the constant noise from the cooling fan.

glxinfo | grep --ignore-case vendor

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
Vendor: Intel (0x8086)
OpenGL vendor string: Intel

Is there way to switch to the nvidia driver with a performance that is better than the 0.1fps?

Post

inxi -aFz

Use X11 + Nvidia proprietary driver.

As I know - you need nvidia_drm.modeset=1 in kernel to use Wayland
it not setup by default - because walyand support is in very early state in Nvidia, and only in 550 latest driver wayland become “usable” on Nvidia.

You can easy add/remove boot options, idk why you think this is problem.
In yast2 GUI find boot-oader, or /sbin/yast2 bootloader in terminal - and change therein second tab.

You can also add/delete nvidia_drm.modeset=1 in grub-menu when boot - during grub-boot press E on menu with boot options and edit
there.

Thank you for the answers.
I didn’t want to play with Grub kernel parameters.
I created a new file /etc/modprobe.d/51-nvidia.conf with the following content:

nvidia_drm.modeset=1

But it did not work.

I went back to X11 + Nvidia. Now the GPU usage is normal.
I will give Wayland a try a few months later.

Driver may be loaded in initrd in which case your file is too late.

1 Like

I agree. Also, to have done the test, it was much simpler and faster to press “E” on the openSUSE boot entry and temporarily add the change than to have had to create the file as the user has done.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.