High CPU after boot due to X/plasma


I’m having a weired behaviour of my kde plasma. After startup, X and plasma are both running at more than 20% CPU each and slowing down everything. The panel and other plasma tools are almost not reacting.
The only way I can stop this is to unlock/lock the widgets. Then the CPU goes down instantly to 1% or less and I can start working.

I tried to remove the widgets one by one, or removing special effects but it did not help.

I’m getting sick of doing this unlocking of widgets at startup and want to fix it once forever.

Using kde 4.1.3 on openSuse 11.1

Update: I forgot to say that the problem is not really similar to http://forums.opensuse.org/applications/415239-xorg-plasma-high-cpu-usage.html. It happens for any user I have and is not a plasmoid

I would try and upgrade KDE to 4.3.x using the guide provided here.
It is much more stable and has loads of new functions. See if this solves your problem.

Good luck…

HI Dexter

Thanx for the hint! That did definitely the job. As a side effect, the terminal doesn’t crash anymore when closing.

I can only suggest to update to kde 4.3!

Glad it worked. KDE 4.1.3 was very buggy. KDE 4 only started to get really good at 4.2.x and 4.3.x only made it better.

Hope it all works for you now. Welcome to the forums by the way! :slight_smile: