Hidden SSID Wifi on 11.3 KDE NetworkManager

Hi Forums,

I have set up an Laptop a couple of days ago, and I can’t help myself getting wireless to work reliably and comfortably in OpenSUSE 11.3 KDE. If I manage to get connected, the connection is superb, so the driver and the signal is working well.

The problem is the managing. The network has a hidden SSID, I haven’t succeeded in setting it up in KNetworkManager at all. Done all the settings in the connection manager, including setting WPA2, but the Applet only shows the profile with the SSID as an unprotected and unknown network.

I tried KDE-wicd, but I couldn’t set up the network either.

Finally I tried the nm-applet from the Gnome environment. It seemed promising at first sight, there was an option in the applet to connect to hidden networks. But the problems didn’t stop there. Every time I restart nm-applet the network is gone from the list and I have to manually connect it by clicking on “connect to hidden network” and choose my connection from the list. I have to type in the password for the Keyring (I choosed the same as for KWallet for simplicity) and then after that repeatedly the WPA2 Key of the network, until the network finally is shown in the dropdown menu of the applet. After clicking on it, it will either disappear and fail, or connect - but it only succeeded to connect once yet.

The signal strength is good, so it is not a connection problem, and as I have used Mandriva on my latest Laptop installs the network must be OK, because the applet used by Mandriva-KDE is working absolutely fine, with no problems at all, remembering my hidden network and automatically connecting without any problems.

Another problem is, that I don’t know where to disable KNetworkManager and set up nm-applet to be used as default in KDE. I searched in the KDE-Systemsettings as well as in the YaST runlevel editor and couldn’t find any entry to KNetworkManager, but it’s still respawning every time I reboot, and sometimes even after standby/hibernate, blocking nm-applet.

Has anybody recommendations what manager to use and how to use it to get connected to a hidden wireless network automatically and reliably once I set it up correctly? Is there a possibility to use the Mandriva default Applet (NetApplet?) in OpenSUSE as well? Because it worked absolutely fine there.

I couldn’t find much information about NetApplet, but it seems Novell herself has developed it for the SuSE procucts some time ago, so I hope it is available for OpenSUSE anywhere.

Hi I would recommend using knetworkmanager as it works great IMHO. After configuring the profile be sure to select connect automatically and after that issue this command :

iwlist wlan0 scanning essid 3springsfarm

where You have to replace 3spingsfarm with your SSID. After that it should just connect. If it doesn’t another thing You can try is unhiding the network for a while connect to it with the profile and than hide it again. It should be working without issues from there on.

Best regards,

Thanks for your hint, it is finally working now as “well” as with nm-applet with that stick. After all it may be a hardware/driver problem too. I tried another wifi USB stick and now it works. Pretty weird, as the not working one worked flawlessly two days ago with openSUSE when it succeeded to connect as well as with Mandriva live and it still shows a working connection, just failing to authenticate.

I’m really glad that it works. I don’t think it’s a hardware problem as I had to use this workaround to connect to a hidden SSID with any wireless adapter I have configured. I really don’t know why knetworkmanager works this way but once it marks the network as secure it doesn’t cause any problems whatsoever.

Best regards,

My network does not work - as like yours its hidden.

The only way I’ve been able to get it to work reliably is to use ifup option set in the network settings in YAST and not use knetwork manager.

This is perfectly fine if you are using a desktop - but with a laptop you need to constantly change the options.

Did You try configuring the networkmanager profile and then issuing the iwlist scan command ? I know that in your case ifup is probably better as it connects much earlier than using networkmanager but still I was just curious if it works for You :slight_smile: By the way networkmanager is also very nice when You need the roaming feature but I guess You don’t use that at home.

Best regards,

I finally got to the conclusion that my Wifi router is just very slow in accepting the connection, or NetworkManager really slow establishing it. The wait time is not long enough for it, so it fails repeatedly before randomly succeeding. I still need some attempts to get connected to the router. Maybe you should give KNetworkManager some time and try multiple times as well.

I really don’t like it that way, but at least I get a reliable connection now after some tries without fiddling in the configuration. I have to wait until I get my Laptop to another access point to figure out whether it is NetworkManager or the router.

By the way, I’m really impressed how fast 11.3 KDE with all those effects is running on this old Dell Latitude d610. Great Work!

In my case the WiFi drivers were at fault as NetworkManager sometimes disconnected from the acces point. Since some version of the kernel (don’t remember which one) the drivers are much better and NetworkManager is super stable now. However the windows drivers are still much better as using Win7 I am able to connect to the access point with 802.11n speed and generally the signal strength is better. With the linux driver only 802.11g works and last time I checked it was a known bug for the athk9 driver and my wireless network card which is :

02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
        Subsystem: Device [1a3b:1089]
        Kernel driver in use: ath9k

Best regards,

I have the same problem as rash_m.

WiFi works for my normal network. But when I try with a hidden network I have problems. However, “ifup” does work with that hidden network.

The plot thickens. I actually have two laptops.

Older laptop: opensuse 11.3 32bit, atheros wireless card, knetworkmanager works just fine with the hidden network.

Newer laptop: opensuse 11.3 64bit, broadcom wireless card, knetworkmanager fails to connect to the hidden network (but ifup is okay).

To experiment, I temporarily unhid the network. I still had problems with the newer laptop. The SSID contains the ‘$’ character. I tried escapting that with a backslash. Once that was done, I could connect when the SSID is not hidden. However, it still did not work with hidden SSID. I did not have a problem with that ‘$’ in the older laptop, at least with 11.3. I did have big problems when it was running 11.0 and had to use Windows to connect to that network.

What’s the difference between the two laptops here? One possibility is the different wireless card. But since the newer laptop does work with “ifup”, I am doubting that. That leaves me wondering whether knetworkmanager is buggy on 64 bit systems. If that turns out to be the problem, then I would just switch to 32bit, since the 32/64 choice is not very important for what I do.

I have problems connecting to hidden networks with 64-bit KNetworkManager also.

glistwan, are you 32-bit?

Yes I’m running 32bit openSUSE.

Best regards,

Well, so much for that idea.

I experimentally installed 11.3 in 32bit mode (on a different partition). It still won’t talk to a hidden ssid network.

I guess that leaves the problem as related to driver and/or wifi card.

Sorry to hear that. I must say that my wireless card is really nicely supported by the ath9k driver. It’s the least problematic wireless hardware/driver combo I have ever used in linux :slight_smile: You can still hope that the drivers for your device will improve in the future as this is changing really fast. I still remember the sad times I had to use ndiswrapper (I used a different wifi card back then however).

Best regards,

On 01/07/2011 04:06 PM, nrickert wrote:
> Well, so much for that idea.
> I experimentally installed 11.3 in 32bit mode (on a different
> partition). It still won’t talk to a hidden ssid network.
> I guess that leaves the problem as related to driver and/or wifi card.

Absolutely not! Blaming the driver/card in this case would be like blaming the
driver or hardware for a failure to read/write ext4 file systems while ext3 are
just fine.

One a connection is made, the fact that the ESSID is hidden makes absolutely no
difference. The driver and the card just transmit what they are told to do, and
read all the data directed to them.

Note that I am opposed to hidden ESSIDs. They provide no extra security. A
would-be intruder only needs to sniff the wireless traffic for a few seconds to
discover that an active network has no visible beacons, and is hidden. Once that
information is available, it is easy enough to get the AP to cough up its ESSID
by probing its channel. After all, that is exactly what your interface does when
it wants to connect.

Another bad thing is that when someone installs a new AP, they do a scan to find
the least-used channel in the clear set of 1, 6, and 11. If your AP is hidden,
they will not see it and are likely to sit on your channel, thereby increasing
your interference and decreasing your throughput.

In case someone does not know why channels 1, 6, and 11 are the only ones to
use, it is because the channels are spaced at 5 MHz, but the bandwidth is 20
MHz. You can do the math.

I agree. But that does not help me. When I am visiting relatives, I get to use the network that they setup. I don’t have a choice.

When I’m at home, and I am replicating that network for testing purposes, I can hide/unhide as needed for testing. But when I am at the real network rather than my replica, there isn’t a choice available to me.

The last time I visited, I had to use Windows, since opensuse (running 11.0 at that time) would not connect to their network. It looks as if I can at least switch over to “ifup” mode this time, though that’s not an ideal solution.

In short, your post was not at all helpful.

On 01/07/2011 04:43 PM, Larry Finger wrote:
> On 01/07/2011 04:06 PM, nrickert wrote:
>> Well, so much for that idea.
>>Manage Connections
>> I experimentally installed 11.3 in 32bit mode (on a different
>> partition). It still won’t talk to a hidden ssid network.

To find if there is a problem, I changed my AP to have a hidden ESSID. I then
created a new account so that there was no history of connecting to that account
and logged into that account. This is a 64-bit system, the wifi device is a
BCM4321 running on b43 using the latest driver from wireless-testing. The
network is controlled by NetworkManager and knetworkmanager as the KDE applet.

I created a connection using the Manage Connections entry in the applet. In the
Connection Manager, I selected Wireless and added the connection. Because it was
hidden, I could not use the “scan” option, but entered the ESSID for the
network, then selected the wireless security tab and entered the WEP key to
match the AP. When the kwallet option popped up, I said to keep the secret in
the wallet, which I chose not to have a password so that I could connect to any
network without having to enter anything. When the wallet asked, I told it to
always provide this secret. After saving everything, I went back to the applet
and selected this connection, which came up right away. In other words,
everything was normal.

If you are having trouble connecting to a network with a hidden ESSID, and you
can connect when the ESSID is not hidden, then you have a configuration problem.

On 01/07/2011 07:06 PM, nrickert wrote:

> In short, your post was not at all helpful.

I’m sorry that you are offended, but you are the one that thought the driver and
wireless card could be causing the problem with connecting to a hidden ESSID.
What level of sophistication should I assume?

Even though you might not need the elementary tutorial, there might be some
readers of this thread that will learn.

No, I’m not offended. But you asserted that I was wrong about the driver or card, and then you went into a long essay which offered no explanation and no alternative possibilities.

You made an assertion with no accompanying explanation and no alternative suggestion. What’s to learn from that?

You could at least point out where you think I went wrong in the process of elimination that I went through, to rule out other possibilities.

And that is exactly what I did, with the exception that I did use a password for kwallet.

It worked on one computer. It didn’t work on the other computer. The only significant difference, as far as I can tell, is the card and driver.

That’s fine to say. Unfortunately, that isn’t how things worked out in practice.

I had to install compat drivers, but I found atheros drivers that may work better, but I can’t tell which to install. Atheros Communications
There isn’t a real clear option from atheros’ site, the drivers may be depreciated.
I’m currently using ath9k for my AR9287