hidden / buried panel

I selected the hide option for my panel at the bottom of my desktop, and it buried itself into a barely visible blue line.

I added a new one on the top, and accidentally had the same thing happen.

I have a last one on the side of the desktop, but obviously this is not optimal. How do I get the barely visible blue line to expand so I can delete or re-set it? Thank you.

It seems that you are talking about using a desktop. But you fail to tell which Desktop Environment you use (KDE, Gnome, …).

Must be KDE, talking about adding panels …, not in GNOME or one of the others.

@OP: Logout, at the login screen hit Ctrl+Alt+F2, it will show a login prompt. Login with your username and password and do:


rm -rf ~/.config/plasma*

Hit Ctrl+d to exit
Hit Ctrl+Alt+F7 to return to the login screen
Login and you will be presented with the default plasma desktop.

Thank you, that worked.

For future reference, I take it there’s no easy way to save all your desktop settings so you don’t have to manually reset them?

Well, for the Plasma settings, you can copy the plasm* files from ~/.config , but there’s no guarantee that a restore will work in two years.

Okay, it turns out it didn’t work.

It did wipe my settings, and give me a fresh panel, but the semi-hidden blue bars are still there on left and bottom. I’ve wiped that file twice, so they must be located somewhere else. Would love a way for force them into visibility.

Either that, or I don’t understand the autohide option. Is there some key that will open / unhide the panels? I think these dead ones are interfering with my cube animation as settings changes don’t take effect.

If I have 4 desktops, can I kill desktop #1?

Not sure why but yes

If auto hide is on you should get a blue line when mouse is close and panel should pop when mouse hovers over line. Not sure about side panels never played with them. One is plenty for me.

I just get the blue line, but it doesn’t pop up. I had to create a second one for functionality, and accidentally hid it the same way. Erasing the config file wiped settings, but doesn’t seem to have killed the two problem panels. (And I can’t hide them, obviously)

How can I kill these two panels and get the auto hide working again?

I think I have them on three sides, actually. Bottom and both sides. Quite annoying. I just tested it again… and wiping config will kill the three hours I’ve spent tuning the desktop effects (while not killing the panels). Great…

Any help to unlock widgets?

Ok now I see what it probably is. Did you set activities for the edges? That produces a blue line if you move along triggers what ever effect you choose. I only set effect for corners thus did not notice the blue lines before

YES! I unchecked (under Desktop Effects) Screen Edge (Highlights a screen edge when approaching) and the blue lines went away. I think something about this setting was overruling the panel(s). Initially, a panel or two still disappeared when I selected Auto Hide, but after 3 tries it started working again. Got panels working again, Thank You!!!

Panel not responding to > Unlock Widgets > More Settings > Visibility … Any setting chosen will default (after a while) to ‘Always Show’ (Panel is always visible)… need to log out and back on again for the Panel to behave as configured?

Any ideas how to fix this?

Thanks

G