Hibernate works but not restart or shutdown in EFI mode

Hi, I’m new in OpenSuse and, I love it :wink:

However, I was using Windows 8 in a “modern” Sony Vaio, and when I tried to power the pc, the entirety disk was empty showing 699GB RAW…
So, I decide to install a Linux distro, in my experience, OpenSuse cumple with my specs.
I’ve deleted and re-partitioned the disk, and “everything” works, suspend, Intel OpenGL (AMD Radeon and fglrx overheat my hardware), hibernate, USB, HDMI, Audio, video, etc…
BUT I’ve a problem that is driving me crazy, GRUB2 EFI won’t boot in a “shutdown or reboot”, but when I suspend-to-disk, it boot so fast and fine.

How do I boot from reboot or shutdown? Well, with the PC off, I press Asisst button and then select “Continue with Windows” and OpenSUSE boots, or inserting the Windows Recovery Disk and no pressing the key, the same efect.

If i don’t do this, Grub2 won’t load, just a black screen after VAIO logo. This DON’T HAPPEND NEVER when I suspended to disk.
That is so “rare”, however, I think that is an “bug” in the GRUB2 “normal” boot configuration.

In resumen, When turn-off or reboot, I have to press the Assist button or insert a CD/USB booteable. When I suspend to disk, can boot normally.

I was investigating in Google for 3 days, and I was fond any answer.

Thank you for answer :wink:

If you need more info, like a file, the output of a terminal, etc, tell me :wink:

I’m not sure what is happening, though it is probably fixable.

You are having a problem with your UEFI Bios.

In any case, here’s an experiment you can try. As root, use the command

# efibootmgr -v

That will list the boot options that are supposed to be available. And each option will have a number (perhaps 0001).

Find the number for opensuse.

Once you have that number – I will call it xxxx – then try the command

# efibootmgr -n xxxx

That is supposed to tell it what to boot next.

I am interested in finding out if that solves your problem. It is possible that when you hibernate, an “efibootmgr -n” command is done to tell it what to boot to recover.

Even if this works, you would have to do it every time. So it isn’t a permanent solution.

There are some other threads on UEFI and VAIO. I think you have to copy the opensuse boot stuff to “/EFI/Boot” in the EFI partition, then do a rename, to get it to work. Perhaps the person who has solved VAIO problems will be able to step in and comment.