Hibernate sometimes works

I’m on openSUSE 13.2 i586 with GNOME on a Dell Latitude D620. Sleep/Standby works fine, but Hibernate only sometimes works. About every other time I try, it will get to the screen where it saves to the disk and stop. It stays at 0%. Pressing backspace (as it says I can to cancel) does nothing. The machine isn’t completely frozen, as the prompt cursor is blinking and does speed up when you press a key (such as backspace). I have the same problem with Hybrid Sleep, but I only tried that once. The times that it does work it takes no time at all and immediately starts saving to my SSD as soon as that line appears on screen. The system then powers off and later resumes successfully.

Any help is much appreciated,

Is this problem specific to the D620, or is it also seen elsewhere? A fix for another computer with the same problem might work for mine.

I can’t say for sure if it is a D620 issue specific but I have troubles with my D630 returning from hibernate or sleep. With the latest updated Kernel I can get 4 sleep/resume cycles and with the originally installed Kernel I can get up to 12 before a failure occurs. Looking at some of the kernel messages, it looks like it is having a hard time with some kind of CPU lock or something to that effect. I have the Nvidia graphics card and thought it might be an Nvidia driver issue. I have used both the nouveau and Nvidia proprietary drivers with no change in reliability. I have it narrowed down to the Kernel as being an issue. I had no troubles with the 13.1 version Kernels so I am thinking it might be time to test some newer kernels or just stick with the older kernel.


Well, I have Intel graphics, so if we have the same problem, then it’s not the Nvidia driver. My always sleeps and resumes from sleep successfully. When it does hibernate, it resumes successfully. The problem is that it doesn’t always hibernate. It will sit at 0% when trying to save to the disk. Other times it immediately writes to the disk and works fine.

Where can I find a log for s2disk? I’m sure there’s something in there.

My kernel is 3.16.7-21-desktop. Do you think that I should try upgrading to 3.19.8 or 4.0.5? I don’t want to ruin this computer. I am haveing some problems with hardware video acceleration though (vaapi errors).

On 2015-06-07 21:06, DaAwesomeP wrote:
> Where can I find a log for s2disk? I’m sure there’s something in there.

No such thing, it is impossible.

Events are logged to syslog, till the moment that the writing to disk is
blocked. Further entries are in RAM, which is then swapped to disk, and
hopefully restored to ram, and then written to disk when the machine
returns from hibernation successfully. If things go awry, nothing is
written of the interesting sections.

Somethings are written to the screen. You may use a serial port (a real
one, not via USB) to write the lines to another machine. It is also
possible to dump some using the ethernet card.

Once I had to modify the kernel myself so that it wrote some log
information directly to the screen, and I took photos.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Some useful info here for debugging that might help here:


This computer does have a Serial cable (it’s old enough), but I don’t have a male-to-male serial cable or adapter, so I wouldn’t be able to plug it into another computer. I could try connecting the three pins I really need (RX, TX, GND) with alligator clips, but they’re probably too big and will just bridge all of them.

Do you know where I can find instructions for logging to the network or displaying it onscreen (with the modifications that you mentioned)? That’s probably my best option right now.

Thank you all for your replies and help. I’m really liking openSUSE the more I use it.

You may check the swap size and if you are using a lot of swap when the failure happens. The hibernate image is stored to swap. Though compressed. some things compress better then other so you should have more swap then memory and if you are short on memory it may be using some of swap so there may not be enough room for the image,

I see. I just tried to shrink my main Btrfs file system in LVM to then increase my swap by 1 GB, but YaST, but…why can’t YaST shrink an LVM volume? I used to be able to do this just fine with system-config-lvm on Ubuntu/Debian systems.