Hibernate is no longer working after system patch upgrade

Yesterday (May 20, Melbourne time) I installed the patches as I normally would do. Later I realised that the system does not hibernate (suspend to disk) and remains on in a locked state (no keyboard or mouse, the screen showing the penguin going to sleep). So far after numerous attempts I have managed to get it to hibernate on two occasions but I cannot isolate as to why on these two occasions it worked. Prior to the patches I had no problems with the system. The way to get the system back is to press the on/off switch for a minute and then does a cold boot.

System configuration is on an i386 platform running 12.3.

Here is a sample of the /var/log/messages file:

2014-05-21T07:52:37.018627+10:00 linux-ecrt-aos systemd[1]: Starting Sleep.
2014-05-21T07:52:37.019986+10:00 linux-ecrt-aos systemd[1]: Reached target Sleep.
2014-05-21T07:52:37.022954+10:00 linux-ecrt-aos systemd[1]: Starting Hibernate…
2014-05-21T07:52:37.045534+10:00 linux-ecrt-aos systemd[1]: Started Network Manager Script Dispatcher Service.
2014-05-21T07:52:37.136208+10:00 linux-ecrt-aos systemd-sleep[3710]: /usr/lib/systemd/system-sleep/atd.sh exited with exit status 1.
2014-05-21T07:52:37.138342+10:00 linux-ecrt-aos systemd-sleep[3710]: Suspending system…
2014-05-21T07:52:37.741596+10:00 linux-ecrt-aos network[3873]: redirecting to “systemctl --signal=9 kill network.service”
2014-05-21T07:52:39.551625+10:00 linux-ecrt-aos kernel: 138.259542] PM: Marking nosave pages: [mem 0x0009f000-0x000fffff]
2014-05-21T07:52:39.551683+10:00 linux-ecrt-aos kernel: 138.259556] PM: Basic memory bitmaps created
2014-05-21T07:57:58.030001+10:00 linux-ecrt-aos rsyslogd: [origin software=“rsyslogd” swVersion=“7.4.7” x-pid=“580” x-info=“http://www.rsyslog.com”] start
2014-05-21T07:57:58.034806+10:00 linux-ecrt-aos kernel: 0.000000] Initializing cgroup subsys cpuset
2014-05-21T07:57:58.034829+10:00 linux-ecrt-aos kernel: 0.000000] Initializing cgroup subsys cpu
2014-05-21T07:57:58.034833+10:00 linux-ecrt-aos kernel: 0.000000] Initializing cgroup subsys cpuacct

Here is the var/zypp/history file:

2014-05-20 06:32:31|install|libhdhomerun20100828|20100828-1.6|i586|root@linux-ecrt-aos|Packman Repository|2dd3d2c1fd6e34ab17137130fecab45dc6384cde3a3ab24302a672fa6087927e|
2014-05-20 06:33:36|install|libbinio1|1.4-4.6|i586|root@linux-ecrt-aos|Packman Repository|04f93796f494c1dbc7180d4efa421524a5bb76e1c8d76712a82c75138fab022f|
2014-05-20 08:28:42|install|flash-player|11.2.202.359-50.1|i586||download.opensuse.org-13.1-non-oss|9b23969f2001f9b794d237e746f4228884a1c0203cea9f9ebda914614371a844|
2014-05-20 08:28:42|install|flash-player-kde4|11.2.202.359-50.1|i586||download.opensuse.org-13.1-non-oss|919467baf19d1f24727b50a4032a0b8ec0cca77d43028602e60d2f95de949e93|

2014-05-20 08:29:21 MozillaFirefox-29.0.1-24.1.i586.rpm installed ok

Additional rpm output:

Unknown media type in type ‘all/all’

Unknown media type in type ‘all/allfiles’

Unknown media type in type ‘uri/mms’

Unknown media type in type ‘uri/mmst’

Unknown media type in type ‘uri/mmsu’

Unknown media type in type ‘uri/pnm’

Unknown media type in type ‘uri/rtspt’

Unknown media type in type ‘uri/rtspu’

2014-05-20 08:29:21|install|MozillaFirefox|29.0.1-24.1|i586||download.opensuse.org-update|ab82d57a6c224316a5b6e98a5f79e143a2c6f955aae5265af1af6e49eedff8f8|

2014-05-20 08:31:22 kernel-default-3.11.10-11.1.i586.rpm installed ok

Additional rpm output:

Kernel image: /boot/vmlinuz-3.11.10-11-default

Initrd image: /boot/initrd-3.11.10-11-default

Root device: /dev/disk/by-id/ata-WDC_WD5000AAKX-00ERMA0_WD-WCC2ED768138-part6 (/dev/sda6) (mounted on / as ext4)

Resume device: /dev/disk/by-id/ata-WDC_WD5000AAKX-00ERMA0_WD-WCC2ED768138-part5 (/dev/sda5)

Kernel Modules: hwmon thermal_sys thermal processor fan libata pata_via sata_via ata_generic scsi_dh scsi_dh_alua scsi_dh_hp_sw scsi_dh_emc scsi_dh_rdac usb-common usbcore ohci-hcd uhci-hcd ehci-hcd xhci-hcd hid usbhid hid-logitech-dj hid-generic hid-holtek-kbd hid-lenovo-tpkbd hid-ortek hid-roccat hid-roccat-common hid-roccat-arvo hid-roccat-isku hid-samsung hid-apple hid-belkin hid-cherry hid-ezkey hid-microsoft ehci-pci ohci-pci

Features: acpi plymouth block usb resume.userspace resume.kernel

2014-05-20 08:31:22|install|kernel-default|3.11.10-11.1|i586||download.opensuse.org-update|99249b105d2f0e13a0755ea7872b99744cb9de7e279837cdf54214162c608b18|

2014-05-20 08:33:25 kernel-desktop-3.11.10-11.1.i686.rpm installed ok

Additional rpm output:

Kernel image: /boot/vmlinuz-3.11.10-11-desktop

Initrd image: /boot/initrd-3.11.10-11-desktop

Root device: /dev/disk/by-id/ata-WDC_WD5000AAKX-00ERMA0_WD-WCC2ED768138-part6 (/dev/sda6) (mounted on / as ext4)

Resume device: /dev/disk/by-id/ata-WDC_WD5000AAKX-00ERMA0_WD-WCC2ED768138-part5 (/dev/sda5)

Kernel Modules: thermal_sys thermal processor fan pata_via sata_via ata_generic scsi_dh scsi_dh_alua scsi_dh_hp_sw scsi_dh_emc scsi_dh_rdac xhci-hcd hid-logitech-dj hid-holtek-kbd hid-lenovo-tpkbd hid-ortek hid-roccat hid-roccat-common hid-roccat-arvo hid-roccat-isku hid-samsung ohci-pci

Features: acpi plymouth block usb resume.userspace resume.kernel

2014-05-20 08:33:25|install|kernel-desktop|3.11.10-11.1|i686||download.opensuse.org-update|eb370260be230fa4ff47df379cbbbddca69c15d97f6f96be73562b5d9c42a61a|
2014-05-20 08:34:11|install|MozillaFirefox-translations-common|29.0.1-24.1|i586||download.opensuse.org-update|dc0b948b0c09dcb8f17098914a39ca0400be6b9f885eedad61057f4a8a61f1f1|

Any ideas as to what I need to do to get hibernate to work?

There was a kernel update did you reboot?

Yes I did. Admittedly, the power cycle reboot happened because of the hang up but since you suggested I was not sure whether I did a graceful reboot. Tried that now and the system still does not do hibernate.

Try the older kernel ie select advanced at the boot and select the previous kernel then try

OK I regressed the kernel to 3.11.10-7 and successfully hibernated three times. I then re-started the system using kernel 3.11.10-11 and attempted to hibernate once again but as stated above the system hangs.

On 2014-05-22 06:26, ElPoppin wrote:
>
> OK I regressed the kernel to 3.11.10-7 and successfully hibernated three
> times. I then re-started the system using kernel 3.11.10-11 and
> attempted to hibernate once again but as stated above the system hangs.

Have a look at file /var/log/pm-suspend.log, and compare copies from old
and new kernel. Do the same with the pertinent section of the messages log.

Maybe you can see something different or that fails.

Another comment: When pasting here computer commands and such, please
use a CODE BLOCK, so that the forum software doesn’t do silly things
like converting URLS to tiny urls or otherwise hide or alter the
commands you entered. You get them by clicking on the ‘#’ button in the
forum editor. See photo


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I finished comparing the files messages and pm-suspend.log. In short neither indicated any errors or major differences:
With pm-suspend.log the only differences were:

  • Reference to kernel version - 3.11.10-11 (not working) and 3.11.10-7 (working) otherwise these lines are identical
  • The memory being used is different every time but there are no issues there as there is plenty of mem and swap
  • The listing of the modules is slightly different
  • The floppy module size is slightly bigger (59500 vs 59468) in the failing kernel
  • The showopts variable is enabled on the failing kernel (I can’t see why this is the case nor why it would matter)

The messages file don’t shed any light either:
Failing kernel 3.11.10-11

 
2014-05-21T07:52:36.932670+10:00 linux-ecrt-aos dbus[571]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
2014-05-21T07:52:36.939760+10:00 linux-ecrt-aos systemd[1]: Starting Network Manager Script Dispatcher Service...
2014-05-21T07:52:36.999787+10:00 linux-ecrt-aos dbus[571]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
2014-05-21T07:52:37.018627+10:00 linux-ecrt-aos systemd[1]: Starting Sleep.
2014-05-21T07:52:37.019986+10:00 linux-ecrt-aos systemd[1]: Reached target Sleep.
2014-05-21T07:52:37.022954+10:00 linux-ecrt-aos systemd[1]: Starting Hibernate...
2014-05-21T07:52:37.045534+10:00 linux-ecrt-aos systemd[1]: Started Network Manager Script Dispatcher Service.
2014-05-21T07:52:37.136208+10:00 linux-ecrt-aos systemd-sleep[3710]: /usr/lib/systemd/system-sleep/atd.sh exited with exit status 1.
2014-05-21T07:52:37.138342+10:00 linux-ecrt-aos systemd-sleep[3710]: Suspending system...
2014-05-21T07:52:37.741596+10:00 linux-ecrt-aos network[3873]: redirecting to "systemctl --signal=9 kill network.service"
2014-05-21T07:52:39.551625+10:00 linux-ecrt-aos kernel:   138.259542] PM: Marking nosave pages: [mem 0x0009f000-0x000fffff]
2014-05-21T07:52:39.551683+10:00 linux-ecrt-aos kernel:   138.259556] PM: Basic memory bitmaps created

Working Kernel 3.11.10-7


2014-05-23T08:59:29.190583+10:00 linux-ecrt-aos dbus[563]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
2014-05-23T08:59:29.192370+10:00 linux-ecrt-aos systemd[1]: Starting Network Manager Script Dispatcher Service...
2014-05-23T08:59:29.209131+10:00 linux-ecrt-aos systemd[1]: Starting Sleep.
2014-05-23T08:59:29.216779+10:00 linux-ecrt-aos systemd[1]: Reached target Sleep.
2014-05-23T08:59:29.217802+10:00 linux-ecrt-aos systemd[1]: Starting Hibernate...
2014-05-23T08:59:29.273359+10:00 linux-ecrt-aos dbus[563]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
2014-05-23T08:59:29.274742+10:00 linux-ecrt-aos systemd[1]: Started Network Manager Script Dispatcher Service.
2014-05-23T08:59:29.288366+10:00 linux-ecrt-aos systemd-sleep[11137]: /usr/lib/systemd/system-sleep/atd.sh exited with exit status 1.
2014-05-23T08:59:29.300805+10:00 linux-ecrt-aos systemd-sleep[11137]: Suspending system...
2014-05-23T08:59:30.175829+10:00 linux-ecrt-aos network[11305]: redirecting to "systemctl --signal=9 kill network.service"
2014-05-23T08:59:31.710092+10:00 linux-ecrt-aos kernel:  4919.813149] PM: Marking nosave pages: [mem 0x0009f000-0x000fffff]
2014-05-23T08:59:31.710146+10:00 linux-ecrt-aos kernel:  4919.813164] PM: Basic memory bitmaps created

Cheers/Saludos tambien

On 2014-05-23 01:46, ElPoppin wrote:
>
> I finished comparing the files messages and pm-suspend.log. In short
> neither indicated any errors or major differences:
> With pm-suspend.log the only differences were:
>
> - Reference to kernel version - 3.11.10-11 (not working) and 3.11.10-7
> (working) otherwise these lines are identical
> - The memory being used is different every time but there are no
> issues there as there is plenty of mem and swap
> - The listing of the modules is slightly different
> - The floppy module size is slightly bigger (59500 vs 59468) in the
> failing kernel
> - The showopts variable is enabled on the failing kernel (I can’t see
> why this is the case nor why it would matter)

All trivial differences, I think.

> The messages file don’t shed any light either:

No, they look the same to me.

Reminds me. Recently I had a machine failing to hibernate, and there was
absolutely no clue in the logs. Sometimes a second attempt succeeded.

If I looked carefully, the machine appeared to go through all the
motions, till the kernel takes over and starts to try hibernation, then
it aborted.

The solution, in my case, was to kill a certain java application
(jdownloader) and kill the network with “rcnetwork stop”.

What I did not try was to increase verbosity. In “/etc/suspend.conf”,
change:


suspend loglevel = 7
splash = n


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Hi Carlos,

OK I have changed the loglevel to 7 and suspended the splash.

With latest kernel the last four lines are:


s2disk: System snapshot ready. Preparing to write
s2disk: Image size 423488 kilobytes
s2disk: Free swap 2103284 kilobytes
s2disk: Saving 105872 image data pages (press backspace to abort) ...(0%)

Then the system hangs. I compared this with the working kernel and it follows the same steps with slightly smaller size file but the free swap disk is the same.

BTW is there a log file for s2disk? I did a search but I could find no reference to an s2disk log file.

Any further thoughts?

Thanks for your help so far.

You can probably run s2disk manually and its option then redirect it to a log file, something like, ( Untested though )

s2disk [OPTIONS]  >> log.txt 2>&1

Tried this option but i could not get it to work. Then I thought I try using the scroll lock and then I was able to read the output properly. But much to my surprise if I toggle the scroll lock the hibernate now works. It does not make much sense to me since the scroll lock was off all day.

On 2014-05-23 09:46, jetchisel wrote:
>
> You can probably run s2disk manually and its option then redirect it to
> a log file, something like, ( Untested though )
>
>
> Code:
> --------------------
> s2disk [OPTIONS] >> log.txt 2>&1
> --------------------

No, logging anything at that moment is impossible. All processes have
been stopped, hard disk is off-limits. Anything like that goes into
memory, and is written to disk after the machine thaws and the
processes are restored from swap. Then pending writes are written.

And after the kernel says it is saving the image to disk, all text it
may display is lost: the image in ram is already frozen and can not be
changed.

The only way to dump hibernation logs during hibernation is to dump them
over the serial port to a different machine.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2014-05-23 13:06, ElPoppin wrote:
> But much to my surprise if I toggle the scroll lock the hibernate now
> works. It does not make much sense to me since the scroll lock was off
> all day.

If it is a bug, then report in Bugzilla.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I have kind of the same problem.

When I click hibernate, it briefly shows the loading screen typical for saving to disk, but then it goes to the lock screen without actually powering off the computer.

If I reboot the computer, then I can successfully hibernate once. After that one hibernation, the above problem happens again every time I try to hibernate without having previously restarted my computer.

For me, too, this started after the last update.

On 2014-05-23 21:36, MikkoFinell wrote:
> For me, too, this started after the last update.

Then, Bugzilla.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Bug has been logged with bugzilla.

Thanks everyone.

On 2014-05-25 13:16, ElPoppin wrote:
>
> Bug has been logged with bugzilla.
>
> Thanks everyone.

Thanks.

You could post the number here, so that others finding the thread with a
similar problem can contribute to it easily :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

The bug was given the provisional number 879792 but a search a few minutes ago it was not in the database. I will check again later today or tomorrow to see whether it has been assigned.

It is in the database:
https://bugzilla.novell.com/show_bug.cgi?id=879792

It’s status is NEEDINFO (i.e. the developer wants/needs more information from you), so maybe that’s why your search didn’t find it.