hi, how can i see network icon?


i have recently installed 12.1 openSUSE. Though I am new to Linux, but have liked openSUSE, it is nice to see.

I use internet, but how can i see the icon of it in the bottom right panel side so that it shows the icon of ‘net being connected’ and when not connected, it shows a red cross or something like that.


It sounds like you have a icon. The red cross just means it’s not connected

no, in fact i don’t have the icon, but want it (the icon). So after having the icon, i can easily see the red-cross (if it is not connected) or other symbol when it is connected…


Typically this icon is only there in a Laptop/Mobile situation

If you want it in a desktop
Install knemo from packman
Then add it via settings (are you using kde)?

Yes, I am useing, KDE. So I install ‘knemo’, but this is amazing that by default it is not seen!


Am 23.11.2011 11:56, schrieb caf4926:
> It sounds like you have a icon. The red cross just means it’s not
> connected
The OP says there is internet, so it is connected. The icon is I think
also a red cross when using classical ifup instead of networkmanager.

PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

After installing ‘knemo’ in KDE 12.1 openSUSE, how to configure it? Should I do it through yast?


As said, when you have a desktop situation (that is you have a fixed cable and the system just sits there, you do not walk around with it), you most probably have a configured using :traditional with ifup". That means that the end-users have no bussiness with the network connection, because it is allways there (at least when you tell them to keep there fingersoff the cable). Like you have no icons for all other hardware items in the system (after all an Operating System is there to HIDE the hardware from the user).

It is only when you are the poor guy that has no fixed place to work and that is walking around with his system to find some wireless connection that you, as end-user, are forced to interact with the network connection. Thus when you do not use “traditional with ifup”, but Networlk Manager", you are shown an icon because you then also have to do some of the work of the system administrator: managing the network connection.

Maybe you are used to another OS where they show you this, needed or not. But you should not take the behaviour of other OSa as being the only correct behaviour in the IT world.

That is correct, but since the Network Manager was just one of the most common options which is not hidden at least in Windows XP. So yes, that is what I guessed here since I was directly coming from Windows XP.

People who work in travelling are no more ‘poor’. There are many other works which are done while travelling – might be sales, company works, etc… , but I have not seen anyone to categorize that type of work into something ‘poor’…!

Well, but that’s why, I am saying that I am not seeing that icon? And for which I should install, ‘knemo’, I guess for network manager…

That is correct and that’s why I have come to use openSUSE and installed 12.1!



I have installed ‘knemo’ but its icon is not coming in the Yast, so how do I open this and enable the sys tray icon for network manager…? Also there is one more pkg. with the name ‘kdes-knemo’, should this also to be installed?


Now please, I may have missed it, but are you using Network manager, or are you using “Ifup”.

If using NM, the applet (and thus the icon) should be there (I can not remember any other thread claiming that is was gone). For KDE this should default to Knetworkmanager, but some use other Network Manager clients in KDE. I do not know what the deafult is for Gnome or other DEs.

When you use “ifup” there is no need for it, but as you still want one, the others seem to have some solution for it.


Current I am using ‘ifup’ but simultaneously I had installed ‘knemo’. So now both are running - (i) ‘knemo’ is letting me see the icon in the system tray (bottom right) and (ii) the option of ‘ifup’ is selected. I am using 12.1 openSUSE KDE (installed via Live CD).

The thing is that when I select, the option ‘User Controlled with NetworkManager’, I am automatically disconnected with the internet…! Now when I go to Yast → Online Update → NetworkManager (search query) → it is installed. So, my doubts are as follows:-

i) Deselecting ‘ifup’ makes internet no more to work…
ii) I have installed ‘knemo’ and then rebooted the system, now there is icon (though I am at ‘ifup’ option), but ‘knemo’ is not seen anywhere in the yast?


You should really use ifup on a desktop

I had installed ‘knemo’

but ‘knemo’ is not seen anywhere in the yast?
How random is that. Maybe you are confused.

I can’t barely follow you. Just a few remarkks on some of your statements.

In YaST > Software > Software management (or going via Online Update if that fits you better), you can see that NetwotkManager is installed. That is the case with all default installations. Nobody said it wouldn’t be installed.

When you in YaST > Network devices > Network configuration change to "user controled via Networkmanager ", it will disconnect the ifup created connections because that is what you tell it.

When you now login in the KDE GUI (maybe you even have to reboot first), the icon representing the applet should be there and usable.

Did you install that knemo using YaST? Then it should be there.

I am still of the opinion then when you use ifup, there is no need for any NetworkManager client (and thus for any icon) because it will not do anything, the NetworkManager server not being active. But others please correct me.

Oh I see, this I didn’t know in fact.

Yes, when I change the option to ‘user controlled via NetworkManager’, it says me three errors:-

View image: My Computer1

View image: My Computer2 (right icon of installed ‘knemo’)

View image: My Computer3

When I come back to YaST, it shows me the error:

View image: My Computer4

Now agan I have checked for ‘ifup’ option and then only I am able to use Internet and not otherwise. ‘knemo’ was installed but I an not able to see its icon any where in the yast, but only at the extreme right bottom panel in the desktop I am using, KDE 12.1 x64 openSUSE.


I an not able to see its icon any where in the yast,

Apart from the rest of your post, why do you think that trhat icon will show up in YaST? Where in YaST? I do not know knemo, but when it is an icon, representing an applet, the you will have it inn your panel lower right.

knemo is not a network manager it is just a network monitor

Image MyComputer 3 above is normal when NetworkManager is set in yast network settings

Make sure it’s installed

su -
zypper in plasmoid-networkmanagement

But you don’t actually need it really if you don’t use wireless.

So knemo will give you a icon on a ifup machine, if you really need it. I don’t bother.

A general comment here.

I installed 12.1 on my desktop yesterday. I had expected to see that red X, but it was not there.

In my opinion, the people who prepared the 12.1 got this correct.

My desktop came up configured to use “ifup”, which is appropriate.

The networkmanager plasmoid is installed, but was not active.

When I check the tray settings, I see that network management is turned off. And that’s why I am not seeing a red X there.

In the beta releases and up through rc2, if I recall correctly, I had to turn off that red X in the tray. It seems that the openSUSE team have done that for the distro when a desktop (or non-laptop) is found.

If you want it on in KDE, then:

1: make sure that widgets are unlocked;
2: right click on the panel, select “panel options” → “panel settings”.
3: move your mouse on the settings window till it is just above the tray. A tool icon should show up. Click on that.
4: on the list of “extra items” check the box for “Network Management”

If the network icon then shows as a red X, you will have to go into Yast, Network Devices, Network Settings, and switch from “ifup” to “Network Manager”. If Yast tells you that there is no network running after that change, then rebooting should get it back.

I did like you said, that I added ‘Network Management’ in the bottom panel and now yes it works, I have changed the default ‘ifup’ setting to the other one (‘User controlled with Network Manager’), but the thing is that still now whenever, I go to yast -> Network Settings and see the edited options, I still get the error:


and ‘knetworkmanager’ is not a package coming (when searched). However, since the above method worked, I have uninstalled ‘knemo’. However, I am not wireless, but still the package ‘plasmoid-networkmanagement’ is installed by default…‘knemo’ also worked well, so even if this fails, I can use and install back ‘knemo’ but I don’t understand what this ‘knetworkmanager’, is the same which I have selected from the panel options (but only there is no ‘k’ in the starting) or something different? And still I am getting the above pictured error. Further, as a matter of curiosity, if at all I want to change my ip address from Yast (means through GUI) where it is? It is not getting depicted in ‘Network Settings’.


That is NOT an error

If it’s working don’t fiddle with IP’s