hewlett packard (intel) pro 3945B/G using 11.0

I’m using HP 520 Laptop, the wireless adapter is Hewlett Packard Intel Pro Wireless 3945B/G.
The wireless is actually working properly, but the button is not.
The problem is :

  1. The radio led indicator is not turned on although the radio is working
  2. I can turn off (kill) the wireless radio but I can’t Turn it back on after. To turn it on I have to restart it or go to shell an do the iwconfig command.

I wasn’t found any of those problem with OpenSuse 10.3,but when I installed (I tried both upgrading and fresh installing) 11.0, the problem came up.

the other differences I found are in 10.3, the default assigned device name of my wireless card is eth1, but in 11.0 it is wlan0, and in 10.3, the default name of wireless card is “Hewlett Packard intel pro wireless”, but in 11.0 it is just “intel pro wireless”.

Is the default 11.0 kernel had just remove the driver/module? Can somebody help me how to fix it? because I often need to turn it on and off to save some power.


That is really strange that your drivers are working correctly, because they shouldn’t be. Intel has stated that the drivers releasted for the 3945 wireless card are not compatable.

yes it is, the only problem is the button (and the led in it)

Intel only said that the drivers you can download from their server are not compatible with certain kernel versions. Perhaps along the line, someone has patched the problems with the driver, since clearly some people using iwlwifi and 3945 cards have working (more or less) wifi.

Iwlwifi driver always had problems operating the LED on my laptop, in 10.3 and 11.0. It’s a driver limitation, which ipw3945 did not share. I don’t usually need to turn on wifi after killing it, but I imagine that issue is similarly a driver limitation.

Have you tried the compat-wireless driver?