Here we go again (no wireless after upgrade, again)

Every time I install or upgrade openSUSE, I lose wireless connectivity. (I have to revert back to Windblows to post these help requests.) This time (after it asks me for the KDE wallet password about a billion times), it just says “Configuring interface” for a while, and then gives up.

I tried the suggestions in the stickies.

Here are some results from the post “Getting Your Wireless to Work”:

YaST => Hardware => Hardware Information
Wireless LANCentrino Wireless-N 2230 BGN
[INDENT=2]Kernel Driver: iwlwifi[/INDENT]

ricky@linux-dc58:~> dmesg | grep firmware
   11.113167] iwlwifi 0000:01:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm

Unfortunately, that post very quickly starts looking like Chinese to me, and I can’t get very far with it.

My results from “My wireless doesn’t work - a primer on what I should do next” are voluminous. Here are the results of the suggested commands:

ricky@linux-dc58:~> /usr/bin/lsusb
Bus 002 Device 003: ID 8087:07da Intel Corp. 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0bda:58bf Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 04b8:083a Seiko Epson Corp. PX-FA700 [CX9300F/CX9400Fax/DX9400F]
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ricky@linux-dc58:~> /sbin/lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
ricky@linux-dc58:~> /sbin/lspci -n
00:00.0 0600: 8086:0154 (rev 09)
00:02.0 0300: 8086:0166 (rev 09)
00:14.0 0c03: 8086:1e31 (rev 04)
00:16.0 0780: 8086:1e3a (rev 04)
00:1a.0 0c03: 8086:1e2d (rev 04)
00:1b.0 0403: 8086:1e20 (rev 04)
00:1c.0 0604: 8086:1e10 (rev c4)
00:1c.4 0604: 8086:1e18 (rev c4)
00:1d.0 0c03: 8086:1e26 (rev 04)
00:1f.0 0601: 8086:1e57 (rev 04)
00:1f.2 0106: 8086:1e03 (rev 04)
00:1f.3 0c05: 8086:1e22 (rev 04)
01:00.0 0280: 8086:0887 (rev c4)
02:00.0 0200: 10ec:8136 (rev 05)
ricky@linux-dc58:~> /usr/sbin/iwconfig
eth0      no wireless extensions.


wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
lo        no wireless extensions.
ricky@linux-dc58:~> sudo /usr/sbin/iwlist scan
root's password:
eth0      Interface doesn't support scanning.


wlan0     Scan completed :
          Cell 01 - Address: 58:6D:8F:A2:14:79
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"Home1"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000012267180ce3
                    Extra: Last beacon: 53ms ago
                    IE: Unknown: 0005486F6D6531
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606080400000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD7F0050F204104A00011010440001021041000100103B00010310470010B74568A8ABEEDBA52B1C03317314890410210005436973636F1023000D4C696E6B7379732045323530301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204532353030100800020084103C000103
                    IE: Unknown: DD090010180205F0040000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 02 - Address: 58:6D:8F:A2:14:7B
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=47/70  Signal level=-63 dBm  
                    Encryption key:off
                    ESSID:"Home1-guest"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000012267181a66
                    Extra: Last beacon: 53ms ago
                    IE: Unknown: 000B486F6D65312D6775657374
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606080400000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD090010180205F0040000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 03 - Address: 86:E9:81:60:E9:FD
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=38/70  Signal level=-72 dBm  
                    Encryption key:off
                    ESSID:"SETUP"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Ad-Hoc
                    Extra:tsf=000000888461ec7c
                    Extra: Last beacon: 53ms ago
                    IE: Unknown: 00055345545550
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010B
                    IE: Unknown: 06020000
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A2C1119FF00000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B080000000000000000000000000000000000000000
                    IE: Unknown: DD09001018020000040000
                    IE: Unknown: DD070050F202000100
          Cell 04 - Address: 00:1F:FB:0C:46:2E
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=36/70  Signal level=-74 dBm  
                    Encryption key:on
                    ESSID:"0C462E"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000001e6aa0f97e9
                    Extra: Last beacon: 53ms ago
                    IE: Unknown: 0006304334363245
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1017FF00000001000000000000000000000000000000000000
                    IE: Unknown: 3D1601050700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B0502000F127A
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: 0706313620010610


lo        Interface doesn't support scanning.



Here are what I think are the relevant lines from dmesg:

   10.047813] Bluetooth: Core ver 2.19
   10.047838] NET: Registered protocol family 31
   10.047839] Bluetooth: HCI device and connection manager initialized
   10.047847] Bluetooth: HCI socket layer initialized
   10.047850] Bluetooth: L2CAP socket layer initialized
   10.047860] Bluetooth: SCO socket layer initialized
   10.425718] cfg80211: Calling CRDA to update world regulatory domain
   10.457902] Intel(R) Wireless WiFi driver for Linux, in-tree:d
   10.457904] Copyright(c) 2003- 2014 Intel Corporation
   10.458066] iwlwifi 0000:01:00.0: can't disable ASPM; OS doesn't have ASPM control
   10.458190] iwlwifi 0000:01:00.0: irq 44 for MSI/MSI-X
...
   10.718260] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
   10.718265] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
   10.718483] r8169 0000:02:00.0: irq 45 for MSI/MSI-X
   10.718639] r8169 0000:02:00.0 eth0: RTL8105e at 0xffffc90004c84000, 5c:f9:dd:54:34:ff, XID 00c00000 IRQ 45
   10.752149] iTCO_vendor_support: vendor-support=0
   10.752309] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
   10.752342] iTCO_wdt: Found a Panther Point TCO device (Version=2, TCOBASE=0x0460)
   10.752439] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
   10.905963] cfg80211: World regulatory domain updated:
   10.905967] cfg80211:  DFS Master region: unset
   10.905968] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
   10.905971] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
   10.905973] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
   10.905974] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
   10.905976] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
   10.905977] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
   10.905979] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
   10.905980] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
   10.905982] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
   11.113167] iwlwifi 0000:01:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
   11.122303] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG enabled
   11.122309] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
   11.122312] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
   11.122316] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Wireless-N 2230 BGN, REV=0xC8
   11.122415] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
   11.143532] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
...

There are a bunch more lines that I can’t post, because they go over the character limit, but they contain messages such as “link down,” “link is not ready,” “L1 Enabled; Disabling L0S,” and “Unable to find TIM Element in beacon.”

This is what YaST2 - Network Settings displays:

Intel WLAN controller                                   DHCP  wlan0
Intel WLAN controller                                   DHCP  wlan0.backup
RTL8101E/RTL8102E PCI Express Fast Ethernet controller  DHCP  eth0

The information for these controllers is:

Intel WLAN controller (Not connected)
MAC : 00:14:a5:2e:ee:96
BusID : 0000:01:00.0

  • Device Name: wlan0
  • Started automatically at boot
  • IP address assigned using DHCP

Intel WLAN controller

  • Device Name: wlan0.backup
  • Started automatically at boot
  • IP address assigned using DHCP

RTL8101E/RTL8102E PCI Express Fast Ethernet controller (Not connected)
MAC : 5c:f9:dd:54:34:ff
BusID : 0000:02:00.0

  • Device Name: eth0
  • Started automatically at boot
  • IP address assigned using DHCP

The post suggests deleting the wireless device and rebooting. Which device, and how can I be assured that it will come back?

I forgot to mention, since the upgrade to 13.2, I get the message “Failed to start Load Kernel Modules” when the system boots up. I don’t know it that’s relevant.

the following script sometimes helps, ymmv,

its basicaly a copy of what’s in the Release Notes,
the top part of the script shows the reaction on this hw

save it with the name network-restart.sh
then start it with cmd

sudo network-restart.sh

#!/bin/sh
#
# restart of network services in case of problems
# after system update
#
# A780GM-m1<2015May04><12:24>

# A780GM-m1<2015May04><12:28><~/Updates/cmds>  sudo sh network-restart.sh
# 
# START
# 
# systemctl is-active network.service
# inactive
# 
# systemctl is-active wickedd.service
# unknown
# 
# systemctl disable wicked.service
# 
# systemctl --force enable NetworkManager.service
# 
# systemctl start network.service
# 
# systemctl -p Id show network.service
# Id=NetworkManager.service
# 
# netconfig update
# 
# END
# A780GM-m1<2015May04><12:33><~/Updates/cmds>  

echo
echo START
echo 
echo systemctl is-active network.service && systemctl stop network.service
systemctl is-active network.service && systemctl stop network.service
echo
echo systemctl is-active wickedd.service && systemctl stop wickedd.service
systemctl is-active wickedd.service && systemctl stop wickedd.service
echo
echo systemctl disable wicked.service
systemctl disable wicked.service
echo
echo systemctl --force enable NetworkManager.service
systemctl --force enable NetworkManager.service
echo
echo systemctl start network.service
systemctl start network.service
echo
echo systemctl -p Id show network.service
systemctl -p Id show network.service
echo
echo netconfig update
netconfig update
echo
echo END

This did not work. Is there a specific directory it need to be saved to?

FWIW, the available wireless networks do show up on the pop-up menu. But when it attempts to connect, it displays “Configuring interface” for a minute or so and then gives up.

no, it does not matter where the script is stored

as the script did not work the only suggestion is to try the following,

in dir /etc/NetworkManager/system-connections/ delete the entries, wlan0*

then in -yast --Network Settings --Global Options —Network Setup Method, select ‘Wicked Services’
then in the other tabs select the appropriate settings for your wireless card

after saving and exiting yast try the script again

hth

There were no such files.

I don’t know what my appropriate settings are. (They say you can’t fix stupid. After 26 years of trying to figure out computer networks, entirely unsuccessfully, I’m convinced that I’m stupid when it comes to computer networks.)

It asks me for the network password. Then, after a few seconds, it asks me for the password again. Ad infinitum.

I tried rebooting, and it automatically reset the network setup method to NetworkManager.

My device is

04:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 2230 [8086:0888] (rev c4)        Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN [8086:4262]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

Which works flawlessly

Your device seems to be working

Perhaps you are just having trouble how to use the Network Manager?

It might be worth cleaning things up and starting over with the Wallet and Network

Delete any entries in the Wireless section of Network Manager

Now view hidden files and delete
.kde4/share/apps/kwallet/
.kde4/share/config/kwalletrc

Logout/Login

Try re-establishing connection

Thank you, thank you, thank you, thank you, THANK YOU! This worked.:slight_smile:

You are most welcome