Help With Wireless Scanner

I have a Brother mfc-j430w Printer with wireless fax…I have the scanner river installed and the scan key tool but when i press the scan button it says to check the connection. I believe i made an arror initially…The command i used was

brsaneconfig4 -a name=Brother_Scanner model=MFC-j430w ip=

I used the wrong ip address…So i tried to do it again with the correct one and it said Brother_Scanner was already registered. How do i remove the first one and do it with the right one?

Available options are shown with

brsaneconfig4 -h

To remove your configuration

brsaneconfig4 -r Brother_Scanner

Excellent! Thank you so much! Now if i can bother you one more time just to make sure i have it right…The code i want to use is…

brscanconfig4 -a name=Brother_Scanner model=MFC-J430W ip=

Is that right?

Everything works now…Thanks for the help…I’m a little smarter than before now :slight_smile:

Glad to be of help. :slight_smile:

Dear Angelbeast and deano_ferrari,

Thank you both! Without your thread, my MFC J430w won’t be able to print from OpenSuSE!

I write a post to explain how to install and configure Linux driver for my new MFC indetail because the official document is not clear. You need to run background process to enable the scanner service. If you want to use the wireless printing, replace USB with IP.

  1. Printer driver need to install LPR and CUPS drivers

  2. Need to run brsaneconfig4 -a name=Brother_Scanner model=MFC-j430w ip=[IP of Brother MFC-J430w] to add scanner configuration

  3. Need to run brsane-skey to enable Scan Key on MFC

Detail: "]Install and Configure Linux Driver for Brother MFC-J430w](

Wish it helps!

Best regards,