Help with Upgrade to Dual Boot

A newer Linux user here. I had XP and 10.3 dual boot installed. I chose the Upgrade option for 11.0 instead of a new install (perhaps foolishly).

After the Upgrade, I was able to fix menu.lst to boot into XP. However I cannot get OpenSUSE to boot. My question is: Any ideas on how to fix the problem(s) below? Or, should I try a fresh install, rather than an upgrade? If so, how do I get the DVD installation to reappear? Even forcing the CDROM as the first boot device, I appear to be booting off the hard disk GRUB.

Thanks for any help/ideas!


The first failure in the boot cycle appears to be:

Unable to find swap-space signature
mount: according to mtab, /dev/sda2 is already mounted on /

The second issue appears later in the boot cycle:

Starting MDRaid
Waiting for /dev/sda3 . no more events
checking file systems…
fsck 1.40.8
error on stat() /dev/sda3: No such file or directory
fsck.ext3: No such file or directory while trying to open /dev/sda3
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

Lookks like your partitions have been altered, or maybe it’s kernel confusion – but whatever, try this: boot off the install DVD and on the first options screen to repair the installed Suse and choose automatic

The DVD is no longer loading at boot. I have the BIOS set to force the CDROM device as first boot device. I’ve also tried invoking the ‘F8’ boot menu to boot off of CDROM. In either case, it appears that GRUB is booting off of dev/sda. I only see the boot items in menu.lst.

I see others are having problems getting the DVD menu to load as well. Strange that it worked initially for me to do the upgrade, but I cannot now see the DVD menu.

You can clear the Grub code from the MBR with windows install media and use the Vista or XP MBR clearing functions. Bit I can’t imagine why the Suse DVD won’t boot unless it’s broken. Can you take the DVD to another computer and see if it has become broken?