Help with uninstallation please

Hello fellow SUSErs, I am new to OpenSUSE, first moved from windows to ubuntu and now from ubuntu to OpenSUSE. Fairly new to linux, and this will probably be a stupid question, but how do I uninstall “Vidalia”? I get some annoying errors with it and tor works on it’s own without needing vidalia gui. I cannot find the uninstall script anywhere or the folder itself. Also cannot find it in add/remove software in start. How do you get rid of it?

Thanks alot!

Well the question is how did you install it and where did you get it??

If from Yast/zypper go toYast - software management and un install it there

If it came in some other package what was it? Generally such packages have readme files which may give you an idea how to remove

Actually, as a regular user of Tor, I seem to remember it was removed from the standard Tor Browser Bundle… maybe 8mths or more ago?

You probably need to describe if you have Tor installed now or any time in the past.
In any case, nowadays Tor should not be installed and used using the OSS unless there is a special reason to do so.
You should instead download and run (requires no installation) from the Tor Project.


I seem to remember that I installed it from “OpenSUSE Software” website, that is already built-in in firefox. It was the 1-click install thingy or so.

Yeah, well I never really installed tor, I just downloaded, extracted it and ran it and it worked flawlessly, it’s the version from tor website allright, so no, I don’t have tor installed, it works without installation.

Then you should be able to uninstall it in Yast=>Software Management, as pointed out. Launch that, search for it in the search box, and uninstall.

Tried that, but it cannot find it when searching for it, is that normal?

If you installed by the one click it should be there but it is possible that it is part of another package so when you search be sure to tick the provides box to get packages that may provide that app or library.You do have to go to Yast - Software management to do the search.

If you manual installed it from some other source or compiled it from source it will not show in Yast

What does this say?

zypper se vidalia

Gogalthorp and wolfi323, thanks to both of you. I managed to find it and uninstall it within terminal. I forgot the command since friend actually did it for me, so I am sorry for not being able to help someone with the same issue! But thanks to all! :slight_smile: And sorry for not replying for 2 days, couldn’t come online.