Help with T-Mobile usb donggle.

hi, im new to Linux and just need some help setting up my t-mobile dongle. openSUSE recognizes the dongle and i can access it under the network connection thing at the bottom of the screen. it shows up as /dev/tty/usb0 when i then click new connection and select it im faced with this screen and i dont know what to do next (see pic).

Id be very grateful if someone could help me
thanks, joe

  • Josnor,

T-Mobile in which country?
For Germany:
Username: whatever
Password: whatever
PIN: The PIN of the SIM in the stick
PUK: leave emoty, or enter the PUK of the SIM in the stick
Number: *99# is correct
APN: internet.t-mobile

That’s all


hi, im from the uk and put the details in you told me but unfortunatel i still cnt seem to sort this problem.

Do i need to put any thing in the network id box.

What do i need to sellect in the screens after i click next.

Thanks for your help, joe

I’m familiar with using E220 and similar usb devices, but not with this service provider. (For Vodafone NZ , I only had to set the number to ‘*99#’ and network type to ‘GPRS’).

I found this blog which suggests:

We didn’t need to manually enter any information about our provider, but for anyone setting up their connection by hand, here’s the relevant information for T-Mobile broadband in the UK.

Number: *99#
Username: User
Password: mms

So maybe this will work for you.

I’ve made quick googling, and came up with these results:
GPRS information and UK settings
APN settings for T-Mobile UK
Mobile Data Settings - What Mobile
You can try them.

These settings should be sufficient:
Username: user
password: wap (or pass)
Number: *99#
PIN: can be left blank (or filled with your SIM card infos)
PUK: can be left blank (or filled with your SIM card infos)

oh that was strange, this time ive plugged it in and its shown up in device manige r as WEB N WALK

I am in the UK and I use a T-Mobile dongle. Up to OpenSUSE 11.2 RC1 I could NOT go online using that dongle - regardless of what I did. Then I played with a live cd of OpenSUSE 11.2 R1 and it… simply worked! No configuring - no passwords, PIN’s etc, just plug’n’play (one click did it!). OpenSUSE 11.2 R1 is now on my laptop and I can enjoy my mobile broadband in Linux. Great job, guys! SUSE ROCKS!!!

Hello Members
I recently downloaded the Live KDE version of openSUSE to run directly from the CD when booting up, i also have a UK (London) T-Mobile Mobile broadband dongle, and the operating system does see the dongle in the connection manager, but i don’t quite understand regarding the settings described in the previous posts.

Is the username to be just written as ‘User’, is the number always *99# regardless of what part of the UK your in , is there a definitive/generic password i.e mms/wap/pass for all T-mobile broadband customers, and is the APN always ‘’.

The reasons i asking for this further help is I’ve never had a ‘username’ or ‘password’ for using my T-Mobile mobile broadband dongle on my Microsoft Windows computers.

Your help would be very grateful regarding the above.

kind regards

the username should be spelt user

is the number always *99# regardless of what part of the UK your in , YES

is there a definitive/generic password i.e mms/wap/pass for all T-mobile broadband customers, and is the APN always ‘’. YES

what makes you special is that you have a simcard and T-mobile knows who is calling in …

For other forums users: this is another delightful querk of Suse that it does NOT use the template that others: eg Ubuntu use; whereby all these apn settings are in the system:

so folks using other distros: eg ubuntu, fedora … merely select country and network; and values already installed;

SuSe; curiously; seems to expect new users to research apn settings and install them … curious …

how to make life hard for new potential recruits to Suse … ???

Why don’t you put a bug report in or a feature request? better still provide it in a Suse usable way.

Though having just had a look, not sure it will need much. So best would be if you can do a local install and assist the devs in how to incorporate it into the distro.

mobile-broadband-provider-info - Please create mobile-broadband-provider-info.doap (see

Thanks a lot pdc_2, i did as you had instructed, and for anyone else out there on a UK T-mobile mobile broadband, the password i used was:…


…none of the other suggested passwords worked for me, i don’t know if these settings are only applicable to account holders in London UK when accessing T-mobile’s mobile broadband network, and whether these settings apply regardless of what tariff your on, i use an ‘Unlimited’ £15 a month package.

There is one query i still have though, in the Live KDE version how do i know what kind of signal strength and signal type i am achieving i.e GPRS, 3G, or HSDPA , when connected by the T-Mobile ‘dongle’?

Again, any advice would be greatly appreciated, and can i just say that this KDE version of openSUSE is really clean and smart and very intuitive to use, thanks to all the open-source programmers out there for creating this.

kind regards

… well … sounds like you are connected …

… for me, that’s a dichotomous state… I’m connected; I’m not;

strength of signal … well …

some folks have looked at installing VMC: vodafone mobile connect that has little bars that purport to show strength of signal:

sounds like it works whatever GSM network you use;

for my usb modems, I just go on the light intensity signal: green=slow; dark blue=better; pale blue=cooking with gas

and seems to depend of time of day; other users etc

what about just enjoying suse for a while?

yes your right, it’s now time just to learn to use SUSE, thanks for the help

Hello pdc_2 and other members, i’m having problems again and need some help, i find i can connect with the T-mobile dongle when running from the Live KDE CD disk the modem shows ‘new cellular connection’ with a heart symbol

I install Live SUSE onto the main hard drive and put in all the relevant details regarding the modem settings i.e *99# etc…, the modem dongle shows an active connection but there’s no heart symbol next to the words ‘new cellular connection’, the light on the modem turns blue but nothing will connect to the net, not Mozilla or the Update manger.

If i hover over the ‘Active’ connection i do get a ‘blue’ box with details telling me i’m connected.

Can anyone help me out i’d be grateful, i don’t no what’s next to do to get connected.

Kind regards

have a look at this thread

pantech usb/verizon 3g connected, but can’t browse… - openSUSE Forums

post #4 pv commented on the /etc/resolv.conf issue;

he is very good on this stuff and resolved it for the person

also an ubuntu thread

[ubuntu] Firefox Connection Problem on Mobile Broadband - Ubuntu Forums](

George Vita is very good on mobile broadband problems