Help with resolution issue

I am having some issues with my screen resolution. I am not sure if it is a monitor or graphics card issue. I believe I have the ATI x300 card. I am running a dell dimension E510. My monitor is a MAG Innovision.
The screen resolution keeps changing. I had this same issue with 11.3. Also, the screen looks fuzzy in certain places at times, especially white areas and bars at the tops and bottoms of pages. By fuzzy, I mean it will be a color that doesn’t belong there and it will kind of look like static, in either a line, or a blob, or just the whole box.
Sometimes there is no noticeable issue, other times it is minor and just annoying, sometimes, it is barley usable.
I recently had to disable all desktop effects because they would make the screen unusable.

Any thoughts?

Thanks

I have an old ThinkPad with same x300 chipset. Its using the radon driver (openSUSE 11.3) without any issue. Does failsafe mode work ok with regards to the desktop environment? Do you think it may be a hardware fault developing? You should supply the specs for your monitor, and the connection type (VGA, DVI etc).

Sorry, monitor is connected through a KVM switch (TK-207) through VGA. Product no. LT765, Model no. 780.

Thanks

Sorry, monitor is connected through a KVM switch (TK-207) through VGA. Product no. LT765, Model no. 780.

Thanks

Ok, now that makes sense. The KVM is blocking the EDID (DDC communication) from your monitor, so the radeon driver is not aware of the display capabilities.

Ok. Good to know. Is there a fix here that does not involve removing the KVM?

There are a couple of possible workarounds if using the radeon driver. However, you need to be confident or familiar with editing the Xorg config files in /etc/X11/xorg.conf.d (or create a minimal config in /etc/X11/xorg.conf). If you look at ‘man radeon’, there are 2 potentially useful options available

 Option "IgnoreEDID" "boolean"
              Do not use EDID data for mode validation, but DDC is  still  used
              for monitor detection. This is different from NoDDC option.
              The default value is off.

       Option "CustomEDID" "string"
              Forces  the  X  driver  to  use the EDID data specified in a file
              rather than the display's EDID. Also overrides DDC monitor detec-
              tion.
              You  may  specify  a  semicolon separated list of output name and
              filename pairs with an optional flag, "digital" or  "analog",  to
              override  the digital bit in the edid which is used by the driver
              to determine whether to use the analog or digital encoder associ-
              ated  with  a  DVI-I  port.   The output name is the randr output
              name, e.g., "VGA-0" or "DVI-0"; consult the Xorg log for the sup-
              ported output names of any given system.
              The  file  must contain a raw 128-byte EDID block, as captured by
              get-edid.
              For   example:   Option    "CustomEDID"    "VGA-0:/tmp/edid1.bin;
              DVI-0:/tmp/edid2.bin:digital"  will assign the EDID from the file
              /tmp/edid1.bin to the output device VGA-0, and the EDID from  the
              file  /tmp/edid2.bin to the output device DVI-0 and force the DVI
              port to use the digital encoder.
              Note that a output name must always be specified,  even  if  only
              one EDID is specified.
              Caution:  Specifying an EDID that doesn't exactly match your dis-
              play may damage your hardware, as it allows the driver to specify
              timings beyond the capabilities of your display. Use with care.
  1. It should be possible to create a minimal /etc/X11/xorg.conf to disable EDID, and instead, include a manual modeline (for your native dislay resolution).

  2. The ‘customEDID’ option is interesting (as I think that is a recent inclusion), that allows one to read the EDID from a (hex) file, rather than from the monitor. If you choose this approach you’ll need to bypass the KVM temporarily, and use the get-edid utility to aquire the EDID from your monitor. (See instructions for this in the man page). This will involve installing the read-edid package. I found a suitable package available via the rpmbone site. (I chose the ftp.rpmbone.net mirror).

Sounds beyond my capabilities. Thank you kindly.

Sounds beyond my capabilities. Thank you kindly.

There are hardware-based solutions in the form of inline-EDID emulators like these:

ConnectPRO VGA DDC/EDID Emulator

http://www.kvm-switches-online.com/ddc-ghost.html

That might be the simplest solution for you, if the KVM switch has to stay…

Ok, so I did away with the KVM, but I am still having the same issue. I can turn desktop effects on and it will be fine, but when I reboot it is all fuzzy and messed up until I turn them off. Also, full screen games, such as a frozen bubbles are fuzzy, but not too bad. Thanks

What are the differences in the /var/log/Xorg.0.log file when you do not have the problem (with desktop effects) and when you have the problem (with desktop effects) ?

I also note the X300 (RV370) is deemed as legacy hardware by AMD and they no longer support that hardware for any operating system, which makes support more difficult. Ergo, you may need to look again at the EDID solution suggested. When one has legacy hardware, it often is no longer possible to have a simple solution.

I don’t know if relevant, but I also note this bug report https://bugzilla.novell.com/show_bug.cgi?id=678264 , where a solution given in post#29 in that bug report was this:

Workaround for R5xx users (Radeon X1xx series)

  • disable KMS by adding ‘nomodeset’ to kernel boot options
    (/boot/grub/menu.lst).

  • add the following section to your /etc/X11/xorg.conf.d/50-device.conf


  Section "Module"
    Disable "dri"
    Disable "dri2"
  EndSection

- use this "Device" in your /etc/X11/xorg.conf./50-device.conf

  Section "Device"
    Identifier "Default Device"

    Driver "radeonhd"
    Option "AccelMethod" "xaa"
  EndSection


**Workaround for R3xx/R4xx users (Radeon 9600/X300/Xxxx)**
------------------------------------------------------

- disabled KMS by adding 'nomodeset' to boot options. 

- add the following section to your /etc/X11/xorg.conf.d/50-device.conf

  Section "Module"
    Disable "dri"
    Disable "dri2"
  EndSection

which for the X300 means this to edit one’s /etc/X11/xorg.conf.d/50-device.conf as described below:

**Workaround for R3xx/R4xx users (Radeon 9600/X300/Xxxx)

**

  1. disable KMS by adding ‘nomodeset’ to boot options (simply type ‘nomodeset’ in the initial grub boot splash menu’s option line when booting)
    .
  2. add the following section to your /etc/X11/xorg.conf.d/50-device.conf

  Section "Module"
    Disable "dri"
    Disable "dri2"
  EndSection

Without the KVM, what is reported by ‘xrandr’? (It may be possible to just add an xrandr config command to a startup file).