help with openSUSE installer...

I tried to delete the openSUSE installer from the vista bootloader, but the program deleted the VISTA loader instead of the openSUSE installer…

so now everytime my computer restarts, it only loads the openSUSE installer.

How can do I get the vista loader back and uninstall the openSUSE?

So far, I’ve used the vista DVD, went to command prompt and did the bootrec.exe /fixMbr, but that didnt work…

any suggestions??? i DO NOT want to reformat vista…

Check this
Winhoes no longer likes to boot after fresh install - Page 4 - openSUSE Forums

that didnt work…

the problem is, the openSUSE installer is defaulted to running and doesnt even give me the option to run vista bootloader…

I need someway to either

a) re-install the vista loader to give me the option to run the O/S

b) delete the openSUSE install loader, and then re-installing the vista loader…

either way, i need to load vista

those bootrec.exe /blahblah

does not work…

and i do CANNOT reformat my drive as I have EXTREMELY important files I need…

just didnt think it would be so ****ing complicated with openSUSE

That does not make sense. If the CD/DVD drive has been set to boot first, once you put a bootable media disc in there it will boot from that, be it an openSUSE cd/dvd or windows.

oops sorry…

basically, when i boot from my vista DVD, and try doing the fixes thru command prompt, it just does not fix vista.

when i run from my harddisk, i go straight into my linux instal loader… which i do NOT want to happen.

any help?

Why not try from the sticky at the top of the install/boot/login page.

Fixing vista multiboot with openSUSE - openSUSE Forums

Good Luck,


I dont have openSUSE installed…just the INSTALLER.

but im guessing i now need to install opensuse to fix my vista?

is there any way to just DELETE the installer through cmd prompt???

Were you installing from within windows?

It might have just happened that Vista had been marked as an inactive partition. I’m not sure if any other tools do this, but if you boot up in a livecd you can set the Vista partition as bootable and that will allow you to boot into Vista. (In theory at least, and only if it’s the case that the Vista partition is not marked as bootable).

For example, this is the output of fdisk -l on my computer:

ian@linux-0gou:~> su
linux-0gou:/home/ian # fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000080

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       18930   152055193+   7  HPFS/NTFS
/dev/sda2   *       18931       30312    91425915    f  W95 Ext'd (LBA)
/dev/sda5           18931       19192     2104483+  82  Linux swap / Solaris
/dev/sda6           19193       21803    20972826   83  Linux
/dev/sda7           21804       30312    68348511   83  Linux

Notice the linux extended partition is set to boot. If you just formated the linux partition, the Vista partition still might not be active.](

The above screenshot is the output of

cfdisk /dev/sda

With this tool you can mark the vista partition as bootable and that should let you boot with Vista.

Good Luck,