Help with network wired/wireless not working

hi all.

I am new to suse and i just installed it today. I can not get my network to work.

Wireless shows no networks at all and wired the ethernet light does not even turn on. I have dpne heaps of searching but i can not seem to find a solution.

if i run lspci it says
Ethernet controller: MarvellTechnology Group Ltd. Device 436c
Network controller: Intel corporation Wireless WiFi Link 5100

in ifconfig i only have lo loopback

Any help would be good.

Also in network settings in yast under overview it has

Marvell Ethernet Controller Not configured

and down the bottem it says

Marvell Ethernet controller (not connected)
BusID : 0000:07:00.0
Unable to configure the network card because the kernal device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

Welcome to the forums.

First, please post some more info:
32/64bit ?
openSUSE version ?
Gnome/KDE4 ?

We’ll see that we get wired networking going first.
Check that cable is connected properly, preferably tested on other machine.
Start Yast, Network Settings,
General - disable ipV6 - set method to traditional (ifup). Reboot and return.
Overview, tick the Marvell, tick edit, leave all settings to default (DHCP etc.),

Open a terminal window and do: ip addr
Please post output here.

Don’t give up, you’ve come to the right place, it’s definitely going to work.

BTW, dutch?

hi

it is 32bit 11.2 gnome.

Cabel is deffinatly working properly.
Followed instrunctions for yast.

ip addr
1: lo: <LOOPBACK,UP,Lower_UP> mtu 16436 qdisc noque state UNKNOWEN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo

there is still no light on the ethernet card either when the cable is plugged in.

as for dutch very dutch family. My opa & oma and all there kids moved to Australia many many years ago and i was born here. Although i have been over to the netherlands a few times. cant speak any of it though.

I’m in he same boat hear. Except, I’ve had Suse 11.2 on this system since it was released. Last night my wifi worked fine, this morning I’m having the same error:

“Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.”

Perhaps the latest set of updates messed something up?

I have an Acer Aspire 3050 laptop with an atherose AR5005G wireless card.

In YaST I have two entries for this card:

AR2413 802.11bg NIC Not configured (Unable to configure etc…)
AR2413 802.11bg NIC DHCP (wlan0)
RTL-8139/8139C/8139C+ DHCP (eth0)

I cannot edit or delete the “Not configured” instance of the card.

I hope this does shed some light on the original poster’s problem, particularly the fact that some recent change (update?) may be the culprit.

Frank

I managed to get my wireless usb modem to work last night. I ran all the updates and now everything seems to be working.

I will keep an eye on it but for the time being everything seems good.

Glad to hear you got your system working.

It looks like my problem is related to the latest kernel update.
( Latest kernel killed my WIFI (Atheros) - FedoraForum.org )

Guess I have to either wait for a fix or re-install 11.2 and NOT upgrade to the latest kernel.

Cheers
Frank