Help with Network Configuration

I need help with network configuration on the latest version of SUSE. I believe I did everything correctly. But it won’t let me connect to the internet. I was doing a wireless configuration, and put in the requirements. It won’t let me connect. I used network manager first because it sounded the easiest. But then I used Yast to configure the network. But after I did that, I didn’t know how to connect to that connection in the network settings. As you can tell i"m lost. Please help me.

I believe I am useing the latest version of leap but not sure. I did see leap when I was installing SUSE on the computer.

Starting from the top. You essentially have two choices to manage your network connectivity: Wicked or NetworkManager. The former is typically used when the network environment is not likely to change frequently. The YaST > System > Network Settings utility is then used to configure the network device(s). NetworkManager provides a user-facing graphical front-end with its own connection editor, and can cope with a number of different connection profiles, useful when changing networks frequently.

This can help with establishing whether wicked or NM is in use…

sudo systemctl status network

An openSUSE networking guide that explains how to configure both network management frameworks…

It might be worth adding that from my recent experiences with a connection problem on eth is that wicked will use wlan if the eth connection isn’t available. Instantly from boot, not sure how long it takes to switch if done while the system is powered up but it did switch.

What happened in my case is that I installed with eth active plus wicked and added a wlan connection later. When I used yast to set that up I clicked use dhcp and filled in the boxes. Net effect - eth0 config file changed to make it the default and some or all of modem manager installed to handle the wifi connection.

In my case both connections are always active but the default network connection is via eth0. I just use wlan0 to access a printer on that network. it switched to wlan0 for net access automatically when the eth0 link acted up.


I just tried disconnecting the wired connection and seeing if wicked would automatically switch to the wifi connection. Gave it 5 mins and it didn’t. :\ So now I wonder why it was switching when I had a faulty eth0 connection. The same could be true of boot. Maybe it only switches if there are faults. Odd aspect is that there did appear to be some attempt to use the wlan connection going on the activity indicator light but browsers were not able to connect to the web.

Just tried again via pulling the lead out of the pc. Same result.



Please try to stay on topic and post only to help the OP here (nalingbird) directly with his problem when you can. When you also have a problem, then please start a thread of your own and do not confuse others with your experiments. Let us keep the technical threads clear, to the point and not confusing.

How exactly did you configure?
Using DHCP or static IP?
If static IP, did you set the DNS’s and gateway IP’s?
If on Networkmanager, it should be no more than enter a passphrase.
If using wicked ( configured through Yast ) the connection should be made automatically at boot.

Please post output of

ip addr
cat /etc/resolv.conf
/sbin/route -n

between CODE tags, the # in the layout ribbon.

Thank you all for helping. I figured it out. Thank you.

Then ideally you should also tell us what steps you made to correct your issue.