Help with mounting and unmounting a dvdrom drive

I’ve just got suse 11.1 on my laptop and have also installed cedega to allow me to run World of Warcraft. I’m trying to install from my DvD but the installer does not show up. Ive surfed and surfed various forums and it seems that on some machines the installation app (the disk is a dual format Win/Mac disc and seems to defualt inside Linux to the Mac version) gets hidden and there is some way to unmount the drive then remount it showing hidden files.

Unfortunately as you may have guessed I am a linux noob and have little to no idea about what syntax to use to do this!

Any help would be fantastic!

You have to first run cedega and click the “Install” button from that program. There you will see something like “Path to EXE” and you need to enter the path to the windows executable there. There is an option to browse and find it. When you browse, go to the cdrom / dvd / disk or whatever from the /media/ directory and select the program. You should select the program from the DVD and usual names are setup.exe, install.exe or autoplay.exe

Warning: I have never tried cedega myself. I am not into gaming :slight_smile:

By the by, there are no 2 different (CD/DVD) disk formats for Win and Mac. Both use iso9660 file system. Another file system called udf is not very popular.

Thanks for the reply, but that doesnt really answer my question. I know how to install stuff via cedega, the problem is not with it.

The problem is that the disk apparently hides the installation exe file (other people have had the same problem and solved it by unmounting and remounting with different options), which means when i try to point cedega to it so it can install I cant because its hideen!

Can you explore the cd from the file browser?

In the tree - look in /media

If you just want to unmount/mount, the commands are as follows: (do it as root from a terminal/konsole)
umount /dev/xxxx
(where xxxx is the CDROM drive device on your machine. If you don’t know this, just type mount and all the currently mounted devices and mount locations will be displayed).
Then, to mount it again, type.
mount /dev/xxxx /media/yyyy -t iso9660 -o ro
(where yyyy is the mount location).