Help with Mobile internet please, I have tried but have hit a brick wall

Hi, I have opensuse 11.1 Gnome on Lenovo S10e. I’m wanting to establish a mobile internet connection.

I have tried so far…*UMTSMON but when I click on it nothing happens. I have reinstalled the program several times to no avail. *WINE to run the Optus program, however the program doesn’t find the HUAWEI USB stick & *Via a Bluetooth connection (use mobile phone as a modem) didn’t work either
Anyhow, I have tried these and some other ways to get mobile to no avail.

Also, have gone to network connections-mobile broadband-add-configure it- but what am I forgetting to do?
Can you please suggest a path I can take to get mobile internet working. (I even have a direct SIM card slot in this laptop if that helps) arhhhh!
Thank you in advance, Adam

Please post the output of lsusb with your huawei modem pluged, and
the last lines of /var/logs/messages


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.

Hi, have been busy - Here is the info
adam@linux-7ipy:~> lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a5c:2150 Broadcom Corp.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04f3:0210 Elan Microelectronics Corp. AM-400 Hama Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 12d1:140c Huawei Technologies Co., Ltd.
Bus 001 Device 005: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 001 Device 003: ID 5986:0241 Acer, Inc
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

**and…/linux-7ipy:/home/adam # /var/logs/messages
bash: /var/logs/messages: No such file or directory
linux-7ipy:/home/adam # cd /var/logs/messages
bash: cd: /var/logs/messages: No such file or directory
linux-7ipy:/home/adam #

I wasn’t able to find info in the messages as you mentioned - haw can I get this to you? (I’m not very experienced in opensuse)**

Sakis3G - All-in-one script

go here

download this

follow sakis’ instructions;

sakis has a list of all connections; opensuse did not in 11.2 and you had to research your apn settings

I removed sim from Huawei device and put it into an older USB stick. Worked! (APN- Connect & Dial *99#) Simple really!

The reason why “nothing happened” with openSUSE 11.1 (read “kernel 2.6.27”) is quite simple:

  1. USB-ID:
Bus 001 Device 008: ID **12d1:140c** Huawei Technologies Co., Ltd.
  1. Most devices from Huawei are supported by the “option”-driver, on openSUSE 11.2 (read “kernel 2.6.31”) we get:
modinfo option | grep -i 140c

alias:          usb:v**12D1**p**140C**d*dc*dsc*dp*icFFiscFFipFF*

Voilà.

Or if we take a look at the source file “option.c” located under “drivers/usb/serial” in the kernel source tree, we find

grep -i 140c option.c

#define HUAWEI_PRODUCT_E140C			0x140C
	{ USB_DEVICE_AND_INTERFACE_INFO(HUAWEI_VENDOR_ID, HUAWEI_PRODUCT_E140C, 0xff, 0xff, 0xff) },
  1. The same for openSUSE 11.1 (no installation running here, so only looking at the same source file option.c from 11.1/kernel 2.6.27):
grep -i 140c option.c

Nada, device not supported by this kernel version.