Help with Live USB Stick

I am trying a couple of USB options for running OpenSUSE. I am confused about using the Live USB Stick option. I bought a 16 GB USB flash drive. I downloaded the Live KDE iso (11.2). Following the instructions on Live USB stick - openSUSE I downloaded the windows image writer (I started this process from my windows laptop) and write the iso to the flash drive. I boot from the stick and choose the Live KDE option. That step that is not explicitly stated and I think it should be since I could easily have chosen Installation. Anyway, I copy the shell script to a file and named it and chmod’ed it as specified. However I don’t see the new partition in the unused space on the flash drive. Even after a reboot. Below is the output of the shell script. I can’t tell if succeeded or not. There is a lot of verbage that might indicate a failure.
Have I done something wrong? Also if I get this accomplished should I attempt an install on the new partition or is this method intended to just start the Live KDE session and just persist stuff to the new partition?

The number of cylinders for this disk is set to 15296.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:

  1. software that runs at boot time (e.g., old versions of LILO)
  2. booting and partitioning software from other OSs
    (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): Command action
e extended
p primary partition (1-4)
Partition number (1-4): First cylinder (679-15296, default 679): First cylinder (679-15296, default 679): First cylinder (679-15296, default 679): First cylinder (679-15296, default 679): Value out of range.
First cylinder (679-15296, default 679): Value out of range.
First cylinder (679-15296, default 679): First cylinder (679-15296, default 679): Using default value 679
Last cylinder, +cylinders or +size{K,M,G} (679-15296, default 15296): Using default value 15296

Command (m for help):
got EOF thrice - exiting…
2+0 records in
2+0 records out
8192 bytes (8.2 kB) copied, 3.4921e-05 s, 235 MB/s

Let’s clarify:
You created a usb stick with 11.2 live on the 16gb sick and booted from it.
You then want to create a new partition using the script.

I’ve never tried it, but why not just try doing it manually?
You can boot from the stick and open a terminal and then type su to run as root.
Type fdisk -l and note the mount for the usb drive (eg sdb)
Now run fdisk /dev/sdb (or whatever the usb stick is).
Follow the script from after ‘fdisk’.

You are wanting to add a new primary partition (2 for the second partition) and use all the space.
I don’t know if this will work since the disk you are trying to partion is mounted, so it may be easier to boot from a different stick and create the new partition.
Alternately, use windows disk management to create the new partion and then boot from the stick and format it using yast2>system)>partitioner to format the disk.

It may be easier to use a different live disk and then to use fdi

I was able to create the partition by running fdisk interactively and using the commands that appear in the script. It hadn’t been mounted - that’s why I said I didn’t see the partition in the unused space. After I ran fdisk interactively I then ran fdisk -l and the new partition was visible so I don’t know what the deal was with the script - I was just following a procedure from the web site. It’s not like I picked up some black magic from web site in left field. It’s part of the OpenSUSE site.

I still would like to know if I am correct in thinking you don’t run the installation and just run the Live KDE session every time.
But the point is moot. That flash drive session was starting to freeze up on me every time I ran it. I saw someone else had the same problem. I also managed to get an installation to an full-fledged USB hard drive that I could boot on my laptop so I am using that.

USB sticks are fine for static storage. They don’t do as well with dynamic data and tend to break down quickly.