Help with Grub booting 11.1 after installing 11.4

AMD 64bit OpenSuse 11.4

My installation on 11.4 went onto its own partition (s) - one for root fs and another for /home. I have encountered intermittent lockups of OpenSuse 11.4 and wish to use my old system as a backup until I can sort this out. Grub is only offering to boot the new system and Failsafe. My other installation does not appear in the menu.

Any ideas on how to diagnose this ?

I have several hard drives on the system with older versions of OpenSuse. The 11.1 release works ok and I would like to boot back into it.

If you run this command: su -c ‘fdisk -l’
You can find out which partition is the root partition for 11.1
Then you can add this entry into 11.4’s menu.lst (the grub config file):

#Don't change this comment - YaST2 identifier: Original name: none#
title openSUSE 11.1 by symlinks
root (hd0,4)
kernel /boot/vmlinuz root=/dev/sda5 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd

In this example sda5 (and hd0,4) locate the 11.1 partition – change them to match your real 11.1 partition.

The method is discussed here for Ubuntu and openSUSE is included in the appendix (be sure to use the openSUSE code template, not the Ubuntu template):
Multiboot Ubuntu, Debian, Mint and similar with Grub in openSUSE

Then you will be able to boot into 11.1 from the existing 11.4 bootloader

Using “fdisk -l” gives a long list of hard drives and their partitions. Not as helpful as I thought. The 11.1 install is on the same hard drive as 11.4. Does that mean that 11.4 has over - written the MBR or does the old boot menu still exist on another hard drive ?

Anyway I will take a look at the menu.1st file on 11.1 and manually copy parts of it to 11.4 and hopefully boot into 11.1

If you know which partition has root of 11.1, then you know exactly what you need to put for (hdm,n) and sdxy in the template. It would also work to copy the entry for 11.1 from 11.1 onto 11.4’s menu which is what you’re booting from now (presumably).

Thanks swerda, this matter is resolved. Manually copying the details from menu.1st on 11.1 to 11.4 worked ok. Grub now displays 11.1 in the boot menu, and the system started without any problems.

Good to know it’s solved.
Be careful if 11.1 has a kernel update – then booting by the method that you just used will will fail because 11.4’s entry for 11.1 will then point to the wrong kernel – but you can do the fix over again and it will work again.