Help with getting internet to work... First attempt at linux...

Hi,

I am reasonably literate, but grew up with DOS and Windows. I tried ubuntu before and found it ok but never persevered.

I have just installed 11.3 32-bit and I cannot access the web. I first tried using a usb wireless (Belkin F5D7050 - Ver. 3) it seems to be recognised and functioning but no web access. I can ping that’s all. Can’t access internet repositories either.

I then tried a wired connection. Again it seems to be recognised and I can ping successfully but no web access or repositories.

I hope I have not missed anything obvious in FAQ’s but I have tried for a couple of hours and am stuck. I would appreciate some help…:frowning:

Are you connecting through an ADSL router?

What does the following return?

cat /etc/resolv.conf

We’re looking for name server IP addresses here.

Meanwhile, read this and see if any of the advice there helps:

how to change dns in suse linux 11.3

This may be useful too:

http://forums.opensuse.org/archives/sf-archives/archives-tips-tricks-tweaks/345507-broken-routers-disabling-ipv6.html

Per the information found here, it looks like your Wireless is supported.


Belkin  802.11g  F5D7050 v. 3000  man: 050d dev: 705a  USB  Ralink  rt2x00  green   Driver included in mainline kernel since 2.6.24.  Firmware is required, see  [rt73usb - Linux Wireless](http://wireless.kernel.org/en/users/Drivers/rt73usb)#device_firmware 

The description of the problem sounds like you have no DNS working. I have a script file that can collect lots of information about your network setup, if you think you could create and run a bash script file on your PC. I am not sure how you are getting online right now however. Here are some possible terminal commands to try and post the output here in a message:

su -
password:
hwinfo --network_ctrl
ifconfig

Get back with this information if you can.

Thank You,

Thanks for replies!

@deano_ferrari - Yes I am connecting through an ADSL router.
resolv.conf showed in last line “nameserver 192.168.1.254” which looks correct. I will check out your links. Thanks.

@jdmcdaniel3 - Wireless seems to be supported. It seems to be using rt73 driver out of the box. Doesn’t seem to be missing firmware.
I am using a Windows 7 box here also which is wired to the router. Copy and pasting to a stick is the only way I can show you what
I am seeing on the openSUSE machine! Cheers.

linux-98x5:/ # hwinfo --network_ctrl
27: PCI 200.0: 0200 Ethernet controller
[Created at pci.318]
Unique ID: rBUF.Kly1Q005z7F
Parent ID: z8Q3.hdHR1LU2D6A
SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: “Dell Dimension 8400”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x1677 “NetXtreme BCM5751 Gigabit Ethernet PCI Express”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x0177 “Dimension 8400”
Revision: 0x01
Driver: “tg3”
Driver Modules: “tg3”
Device File: eth0
Memory Range: 0xdfcf0000-0xdfcfffff (rw,non-prefetchable)
IRQ: 16 (16402 events)
HW Address: 00:11:11:eb:ec:80
Link detected: yes
Module Alias: “pci:v000014E4d00001677sv00001028sd00000177bc02sc00i00”
Driver Info #0:
Driver Status: tg3 is active
Driver Activation Cmd: “modprobe tg3”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)

48: USB 00.0: 0282 WLAN controller
[Created at usb.122]
Unique ID: X7GA.EqTPcXwuUG1
Parent ID: k4bc.9T1GDCLyFd9
SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7:1.0
SysFS BusID: 1-7:1.0
Hardware Class: network
Model: “Belkin 54g USB Network Adapter”
Hotplug: USB
Vendor: usb 0x050d “Belkin Components”
Device: usb 0x705a “Belkin 54g USB Network Adapter”
Revision: “0.01”
Driver: “rt73usb”
Driver Modules: “rt73usb”
Device File: wlan0
Features: WLAN
Speed: 480 Mbps
HW Address: 00:1c:df:a0:34:f3
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “usb:v050Dp705Ad0001dc00dsc00dp00icFFiscFFipFF”
Driver Info #0:
Driver Status: rt2500usb is active
Driver Activation Cmd: “modprobe rt2500usb”
Driver Info #1:
Driver Status: rt73usb is active
Driver Activation Cmd: “modprobe rt73usb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #43 (Hub)

linux-98x5:/ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:11:EB:EC:80
inet addr:192.168.1.6 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::211:11ff:feeb:ec80/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1165 errors:0 dropped:0 overruns:0 frame:0
TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:92968 (90.7 Kb) TX bytes:12854 (12.5 Kb)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:820 (820.0 b) TX bytes:820 (820.0 b)

wlan0 Link encap:Ethernet HWaddr 00:1C:DF:A0:34:F3
inet addr:192.168.1.18 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::21c:dfff:fea0:34f3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21581 errors:0 dropped:0 overruns:0 frame:0
TX packets:519 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2616148 (2.4 Mb) TX bytes:72863 (71.1 Kb)

Hi there,

If you can ping, then you have connectivity at the IP layer - so you are 90% there. As noted earlier, this is a DNS issue.

I know you told deano_ferrari that the last line in /etc/resolv.conf was nameserver 192.168.1.254, which may be correct - if that is your routers address. However, to be sure please do the following>

  1. Power cycle your router (ensures you get a fresh DHCP lease which will include telling the router which nameservers to forward to.)
  2. Restart networking (sudo /etc/init.d/network restart)
  3. Post your entire /etc/resolve.conf
  4. Ping 192.168.1.254, do you get a response?
  5. Trying hosting a domain name out using the host command and specifying a name server to query, e.g: host google.com 4.2.2.2
  6. Go to your routers home page / status page, and see if you can find what name servers where assigned to you in the DHCP lease you received from your ISP. You may have to dig around a bit, or this may be right on the main page when you go to your routers IP. We need to make sure your router know which DNS servers to query when it receives a request.

If you can provide the above information, I believe the problem will reveal itself.

Cheers,
Lews Therin

gocfella wrote:
> no web access

have you tried disabling IPv6?


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

@LewsTherinTelemon - Followed your advice and once I manually entered the two DNS servers from my routers web interface into network settings, I was good to go!

It will take a bit of getting used to that you have to do so much manually, gotten very used to windows doing it “for” you ya know…

Problem solved… :slight_smile: Thanks to everyone who responded, much appreciated…

btw I think my router supports IPV6 incidentally…

This is my first post from my new openSUSE system!
Happy days…:slight_smile:

Good stuff! :slight_smile:

Great - glad it is working :slight_smile:

Great! I am glad it worked. Normally, you don’t have to specify the DNS servers your router is forwarding to in your /etc/resolv.conf - when you get your DHCP lease, it typically will put your router as the nameserver (which will forward to the DNS servers it uses). I am sure we could dig in a bit further, but really as long as it is working now and you know how to fix it, then it is all good.

You do have to do some things more manually than with Windows, though not much these days. However, Linux gives you the ability to do things under the hood in ways that are frankly impossible with Windows. Usually, you should not have to dive into the command line all the time - unless you like to, or unless troubleshooting is needed. The nice thing is that the command line is a wonderous tool for troubleshooting, and when combined with a strong commnity (such as this forum) it makes for a potent weapon.

Hope you enjoy Linux and OpenSuse!

Cheers,
Lews Therin