Help with "duplicate" /home partition


I just installed openSUSE 11.3 via live usb. During the post-install process (user management, network settings etc) something screwed up and it could not complete the whole process. So I could not do any user related settings, mounting options etc. and the system rebooted automatically. All seemed well until I noticed that there were “two” /home partitions.

Previously, I had Ubuntu installed. I decided to get rid of it and try openSUSE. During the install process, I had set the partition manager to format Ubuntu’s “/” partition but leave the /home (/dev/sda8) intact, and also set its mount point as /home. But because of the abrupt rebooting during the post-install process, openSUSE created a /home folder in /, rather than mounting the existing partition (which Ubuntu had, /dev/sda8). Every time I open the User & Group management to modify some setting, it complains as such: “In /etc/fstab, there is a mount point for the directory /home, which is used as a default home directory for new users, but this directory is not currently mounted. If you add new users using default values, their home directories will be created in the current /home. This can result in these directories not being accessible after you mount correctly. Continue user configuration?” I understand what’s going on, but I’m unable to figure out how I can get rid of the current /home directory and make it mount the /dev/sda8 partition as /home?

This is what my current /etc/fstab looks like:

/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part9 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part7 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part8 /home                unknown    defaults              0 0
/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part1 /windows/C           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part5 /windows/D           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8
/dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part6 /windows/E           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

You can move /home to /oldhome and create an empty mount point and mount sda8 on that. However it looks like the filesystem type isn’t set properly in fstab, it shows unknown. You have to fix that first.

Since a user account logins to /home, you’ll need to do this switcheroo from the console as root.

You might want to first try manually mounting sda8 from the CLI on a temp mount point that you mkdir, e.g. /sda8, to check that the partition is indeed intact.

Thanks for your reply, ken_yap. I moved /home to /oldhome and created a new /home to mount /dev/sda8 after fixing the /etc/fstab entry. I even copied all the contents from the old /home/username directory to the new /home/username directory, so as not to lose any configuration settings etc. It mounts correctly, but when I login, the desktop does not load and it gives an error: “Kstartupconfig4 does not exist or fails. The error code is 3. Check.” Clicking the only button available in this error dialog (“okay”) takes me back to the login screen. Any idea what this could mean?

Scratch that. I have fixed the problem. What happened was that my copying the /oldhome/username files, they belonged to root, especially the ~/.kde4 folder and its contents. After chown’ing it, the problem was fixed.

On 2010-11-13 13:36, agent logic wrote:
> Code:
> --------------------
> /dev/disk/by-id/ata-ST3160215AS_9RA5W4JD-part8 /home unknown defaults 0 0

> --------------------

That line is bad.

What Ken says is correct, but you have to verify that partition type and
enter the correct line.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)