Help with Dual Boot

Hey guys, finally got mostly everything fixed on my opensuse 11.3.

11.3 is my only os on my laptop right now and I want to be able to dual boot with backtrack4. I used to have bt3 but it was on a usb loading up with winxp.

Anyway, I’ve downloaded the iso image and after hours of forum reading I figured out how to mount the iso image. Doing so allows me just to look at the files. Is there an install file somewhere I’m missing?

Also, couldn’t ever figure out how to partition my drive to make room for bt4. Tried downloading gparted and failed. Tried using the expert partitioner program that came with this system but it won’t allow me to create another partition. Couldn’t ever find a reason why.

Will bt4 allow me to create a partition upon installation? How do I install?

Thanks for all the help in advance guys, I’m still pretty new.

t looks pretty much like an Ubuntu clone:
Install BackTrack to Disk - BackTrack Linux

Use PartedMagic to create (at least one) partition and write down its name (sda2, sda3, etc). Then boot from the Backtrace ISO and follow the steps in the link above. But at this point:

Do not accept the default an select “manual”. If it is like Ubuntu, you will be able to select the partition you created before. Please do not select any other one, except the swap partition that you can share with openSUSE. You could probably install the bootloader on sda (in the first sector of the hard disk). But since I don’t know this distro, I suggest installing it on the system root parition (the one you just installed bt4). Later you can add a bt4 entry to openSUSE /boot/grub/menu.lst (we’ll explain you how when you reach that point).

An alternative would be to install bt4 in a virtual machine. It looks like it is more often installed in VMware (so the example in my previous post). You could probably install it in VirtualBox as well. IMHO, It would be “less” dangerous than repartitioning your hard disk for that purpose.

Thanks for the reply.

Right now I can’t even run the backtrack iso.

I have it mounted and can access it via desktop but it just opens it up to view the files inside.

I used the nautilus file browser to burn the iso image to a dvd and it does the same thing. I can’t even boot from this disk for some reason? I changed the boot bios so that it would boot from cd first but still no luck.

Any ideas?

I think this distro focuses on virtual machines. Try it in VirtualBox.

  • Become root in a terminal
    su -l
  • install compiling tools and kernel headers (you’ll need that to compile the VirtualBox kernel module)
    zypper in -t pattern devel_basis
    zypper in kernel-devel kernel-desktop-devel kernel-syms
  • add Oracle VirtualBox repo
    zypper ar [noparse][/noparse] virtualbox
    zypper refresh -r virtualbox
  • install VirtualBox. It should take a while as it has to compile the kernel module
    zypper in VirtualBox-3.2
  • add yourself to the vboxusers group
    groupmod -A yourself vboxusers
    where “yourself” describes your login name as user (not root)
  • Now as user (you can exit that terminal), start VirtualBox …
  • Create a Virtual machine
  • Add your bt4 iso in the Virtual Media Manager.
    Files -> Virtual Media Manager -> CD/DVD images
  • Set the boot order of your virtual machine to CD/DVD first
    System -> Motherboard -> Boot order
  • Attach the iso image to the virtual CD/DVD device
    Storage → CD/DVD Device … Replace “Empty” with your bt4 iso image.
  • Boot the Virtual machine and it should boot bt4.
  • Notice that while installing in a virtual machine, the advice I gave in post #2 doesn’t apply. In that case, just accept the default setup.


Virtualization is not like Dualbooting. But It might be satisfaying in your case. Anyway, it won’t hurt to try and you can delete a virtual machine any time once you decide that you don’t need it anymore.

Wow, thanks for the in depth advice! :slight_smile:

I’m going to try all that with virtualbox right now.

Thank you very much. My only concern is that I won’t be able to use some of the tools in bt4 by running it virtually like in vmware or in this case virtualbox.

I had that problem a long time ago where bt3 wouldn’t run correctly in vmware when I was running winxp/vista, but when I could boot from it via usb it worked fine.

Hoping for the best here! I’ll be back with updates!

Hey, everything seems to going fine. Thanks again.

(Sorry for double post)

Only one thing. Like I was worried about to begin with - no internet connectivity. After brief researching I found this:
“Any virtualisation software can only use USB wireless network cards as physical devices, all other types of wireless card are seen as virtual ethernet devices and can only be seen as a wireless device by the host and not by the guest operating system. So if you want to run BackTrack in VMWare or Virtualbox and have full wireless capabilities, make sure you are using a USB device.”
-BT4 official website

:frowning: That kind of defeats the whole purpose. I don’t see getting a usb wireless network card anywhere in the future.
Is there anyone that can still help me to try and dual boot?

Why do you need that? Your Virtual Machine should be connected to the Internet. The ethernet device is virtual but the TCP/IP connection to the host (your openSUSE system) and further to the Internet is real.

On 11/29/2010 11:36 AM, please try again wrote:
> Why do you need that? Your Virtual Machine should be connected to the
> Internet. The ethernet device is virtual but the TCP/IP connection to
> the host (your openSUSE system) and further to the Internet is real.

As stated, using a VirtualBox VM allows you many networking options. The default
is to connect the virtual ethernet through the host using NAT. You will get a
10.0.X.X IP address that can connect through the host to the Internet. You can
also select a bridging connection, which gets you an address from the DHCP
server on your LAN. I use this mode when I wish to ssh into the VM from another
host on my network, or to mount the NFS volumes on the VM. As you quoted
earlier, it is possible to use real USB hardware on your VM. I do this when
debugging drivers for USB devices. My main box runs 64-bit Linux and the VM is
32 bit, thus I test both flavors.

Hey guys, been a while. Virtualbox just wasn’t cutting it for me, I finally managed to get bt4 installed onto a partition created by virtualbox lol virtualbox was the only thing that could create a partition properly.
Since I installed bt4 I can’t access my opensuse! I know its because I have to configure the grub.

Any help?
I was following a tutorial for ubuntu but none of the commands would work :frowning:

I don’t understand where you did install it? Did you use virtualbox to create a partition outside of the virtual machine? (I don’t believe so).
Can you please post the output of fdisk -l from your running Linux.

Not at my comp right now, but I know it lists /sda which is swap and then /sda2 and sda3 are both linux distro’s. One is about 10 GB (after converting the amount of blocks) and the other is 26.5 GB. My total drive space though is 80 GB.
When I setup virtualbox I made a 10GB partition. Then when I just installed bt4 I used its partitioner to make an even split of 26.5GB left for suse and 26.5 for bt4.

I can load up the suse live cd and see both the suse os on my hardrive and all of the files in it as well as the bt drive.

if you see bt4 Grub menu at boot and it uses the same Grub as Ubuntu, just typing sudo update-grub in a terminal would add an entry for openSUSE. That’s how it would work in Ubuntu. If on the other hand it says “command not found”, try to type grub. If it starts a grub shell, it uses Legacy Grub, as in openSUSE. In that case, You could simply copy/paste the openSUSE boot entry from /boot/grub/menu.lst on your openSUSE partition to /boot/grub/menu.lst ont your bt4 partition. But I would assume, since bt is based on Ubuntu, that it uses Grub2.

Using the grub update, it performed some actions. Looked good, but after restart still not able to access suse :-/ Just typing “grub” in bt4 terminal worked too and pulled up:
Minimal BASH-like line editing is supported. For
the first word, TAB lists possible command
completions. Anywhere else TAB lists the possible
completions of a device/filename. ]

I booted up the suse LiveCD to copy the boot menu like you said, but even though I have access to both suse and bt4 partitions and can browse the files, I cannot find it because I can’t find the file systems folder that contains the boot folder?
Is there someplace where I can find it?

Any other help? Thank you for continuing to help me through this problem!

If both commands update-grub and grub are available … hmm I would say that maybe both grub versions are installed (?).
Why not using openSUSE to boot, i.e installing openSUSE’s grub into MBR and adding the bt4 boot entry (see /boot/grub/menu.lst under bt4) to /boot/grub/menu.lst in openSUSE? Which partition is openSUSE, sda2 or sda3?

Here is my fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
16 heads, 63 sectors/track, 155061 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Disk identifier: 0x16351635

Device Boot Start End Blocks Id System
/dev/hda1 3 4176 2103296 82 Linux swap / Solaris
Partition 1 does not end on cylinder boundary.
/dev/hda2 * 4176 45788 20972544 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/hda3 45788 155061 55073792 83 Linux
Partition 3 does not end on cylinder boundary.

hda3 is my opensuse…

alright, I can get to and open menu.lst here in bt4 - but I’m a little lost when you say to install openSUSE’s grub into MBR…

I don’t know why you’re using the old pata driver (should be sda, not hda) or how your /boot/grub/ looks like … But to install openSUSE Grub in MBR, you would type the following in a terminal under openSUSE:

su -l
grub> root (hd0,2)
grub> setup (hd0)
grub> quit

Have a live CD ready …in case it doesn’t boot.

Alright I got:
grub>root (hd0,2)
Filesystem type is ext2fs, partition type 0x83

grub>setup (hd0)
Checking if “/boot/grub/stage1” exists… no
Checking if “/grub/stage1” exists… no

Error 15: File not found


su -l
grub> find /boot/grub/stage1

And what’s the output of:


In suse?

Is there a way to see the file system folder through the users folder?

For ex; when I open the suse partition via livecd it has “Dzanjin” folder and “lost+found” folder whereas the bt4 partition has the file system folders including the boot folder…