Help with DSL setup

Hi All.

Before I ask for help let me give you some idea of who I am. I am a software developer so Linux/Unix is not a new thing to me but I am by far not an expert. I currently use Ubuntu at work and used to have it installed at home as well before deciding to switch to opensuse on the weekend. I switched as I was looking for a KDE distro in order to fix problems with compiz running on 3x nvidia cards each with 1 screen attached. I mainly use the cube and seeing that Kwin now provides this, and I always wanted to go KDE, I have decided to install what seems to be the best KDE distro available, opensuse.

Ok, now my problem. I have installed opensuse twice, once with auto config and once without but neither time have I been able to setup my internet connection. I have a wimax connection that consists of a dish on the roof that is connected to a box in my house, from this box there is a lan cable running into my router and from there into my pc (I have also tried connection it strait to my pc). Because of the lan cable into the router it is not possible to setup my router to make the connection to my isp, believe me i have tried and if some can tell me how to do this it would be great, but because i have not found a solution to this problem i need to setup the os to make the connection. I have this setup in windows(I have a duel boot for games) and also used to have this setup on ubuntu. All i did in ubuntu was open the network connection manager click on the dsl tab, add, insert username and password, apply and the connection would be available by clicking on it in the system tray. After playing around in opensuse it seems there is 2 ways to do this, one using yast, and the other using network manager(looks like the same one as ubuntu) by setting yast network config to user controlled. When using the network manager the setup looks the same as ubuntu but when clicking on the manager in the system tray the dsl connection is not there. When using yast to setup a dsl connection it tries to install some package (smpppt i think) but cant because some other process is using the package manager, i dont know what and cant find it. I do believe when i did the first install with manual config it did install the package but not sure and i couldnt connect anyway.

This is a big problem and really need some help asap. Thanks in advance for the help.