help with configuring new proprietary drivers

Hi, I’m new -and inexperienced- Suse user,
I have a new laptop with an ATI 5650 graphic card. I have been using the Radeon driver with very low performance for a while.
this driver was installed following the “Xorg -configure” procedure as descibed in the forum.
Today I installed the newly released driver from Ati.
this is what I did:

  1. in /etc/X11/xorg.conf I changed “radeon” with “fglrx”
  2. I run the driver downloaded from the ATI website
  3. I run the command “aticonfig --initial”

I’m no longer able to start the X server (the computer boots to full console) and I have no idea how to go forward…
if I give the command “startx” I get a “segmentation error” and I go back to console
can somebody point me in the right direction?
thanks in advance

ok, I might have done something right. I followed, as suggested in another thread the instruction for installing the proprietary driver as per 11.2 “the hard way”. this required the installation of a lot of additional packages.
anyway, I managed to get X started and from the “my computer” link to konqueror I can see that I’m currently using the Ati driver.
So it seem to work but the 3D eye-candies are quite slow…