HELP WANTED: MPEG-4 AVC/H.264 codec in an .mp4 wrapper playing files and editing wioth kdenlive

First off i’m running tumbleweed with plasma 5 on my corei7-5820k@3,3GHz, 16G ram gtx 760 with nvidia 346.47 blob

I own a Panasonix HX-A500 wich shoots to MPEG-4 AVC/H.264 codec in an .mp4 wrapper

Xine wont play of these files, just crahes with no errors printed to terminal.
Kaffeine just shows a black screen with nothing playing and no errors even in terminal.
VLC states the following

  No suitable decoder module:
 VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
 No suitable decoder module:
 VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.

and kdenlive just claims it is loading the movies when i add them to the list of clips i want to make a movie off.

Any wizards here who can help me playing of these movies and edit them with kdenlive?

Also if someone could help getting openshot to work i would be gratefull :slight_smile:
also got openshot from packman.

hallvar@linux-gbhd:~> openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
   OpenShot (version 1.4.3)
Process no longer exists: 2992.  Creating new pid lock file.

------------------------- ERROR 2 ------------------------------
Failed to import 'from openshot.openshot import main'
Error Message: No module named xdg.IconTheme

OpenShot has failed to import some of the Python files or libraries 
required for our application to run.  Here are some trouble shooting

Tip 1) Check if MLT can be successfully imported in Python.  Run the 
 following commands, and see if any errors are displayed.  If you get 
 an error, you need to investigate the correct way to install MLT.
 NOTE:  Do not type the $ or >> characters in the examples below.
       $ python                                                                                                                                                                                                                             
       >> import mlt                                                                                                                                                                                                                        
       >> mlt.Factory().init()                                                                                                                                                                                                              
Tip 2) If MLT is working from the first example, then the next tip is                                                                                                                                                                       
 to look at the above error messages very closely, and google for more                                                                                                                                                                      
 help.  It's likely the problem is already reported, and maybe there is                                                                                                                                                                     
 a simple work-around.  Also, you can search for bugs or report a new                                                                                                                                                                       
 bug at  Good luck!                                                                                                                                                                                    
hallvar@linux-gbhd:~> python                                                                                                                                                                                                                
Python 2.7.9 (default, Dec 13 2014, 18:02:08) [GCC] on linux2                                                                                                                                                                               
Type "help", "copyright", "credits" or "license" for more information.                                                                                                                                                                      
>>> import mlt                                                                                                                                                                                                                              
>>> mlt.Factory().init()
<mlt.Repository; proxy of <Swig Object of type 'Mlt::Repository *' at 0x7f66b0322ab0> >                                                                                                                                                     
>>> exit                                                                                                                                                                                                                                    
Use exit() or Ctrl-D (i.e. EOF) to exit                                                                                                                                                                                                     
>>> exit()                                                                                                                                                                                                                                  

it looks like you don’t have the patented codecs installed (mp3/mp4/h264/aac …)
just add packman as a repo and set it as a system repository (replaces oss libraries that don’t have full multimedia support with packman’s that do) the easiest way to add packman is via zypper

sudo zypper ar -f packman
sudo zypper dup packman

I do belive **zypper dup packman **command updates the system with libraries from packman’s repo, the alternative is to use yast.

Actually i did pull the packman codecs trough

sorry i dint mention it.

however i fixed xine by changing it from opensuse repo to the packman repo.

also got editing working with ligthworks wich was suprisingly simple :slight_smile:

It’s not just adding packman’s repo it’s setting it as the system repo, that’s where dup comes in, I had the same issue if the same package exists in both repo’s yast (zypper) will install the system package and if packman is not set as system repo that package will be the oss package.
Another way to set packman as the system repo is in yast, software management select repositories then select packman then click the blue link saying set this repository as the system.

Aha :smiley: Nice thank you