Help w/ VPN setup?

I have read and read and this stuff is boggling my mind… I have an elementary understanding of what a VPN is and is for. But there are so many acronyms thrown and jargon that is intertwined, that I’m really quite confused at this point. Much of it is a bit deeper than I comprehend or seems not relevant to what I’m having problems with.

Here’s the situation.
Have an Asus mainboard home brew PC been running Linux various versions for several years, no problems.
Running KDE on openSuSE 11.3 and experimenting w/ VPN for the first time ever.

I have created an account with a VPN “host” I guess it is called. (StrongVPN) That is supposed to be my secure pathway if I understand things correctly. They gave me an account number, etc. but what do I do with it now?
It makes sense to me that I would enter the credentials and use a “manager” to connect me to their secure network. But it doesn’t.

I have pptpd; Network Manager; vpnc; openvpn and “strongswan” all installed in YaST.
Don’t know what was actually needed other than the first two and some of these may have been dependencies. But when I search on VPN it shows me all of those installed. I have no concept of what they’re doing or how they’re employed, deployed, etc.

I’ve created a connection w/ Network Manager with the VPN host URL as the gateway, my logon, password, apply / OK and try to connect, nothing happens. The applet runs and says “Activating” but then stops with no connection. When I REexamine the connection properties, the password is blank again. ??
I’m not sure if it isn’t “keeping” the password, or if that’s a security mechanism to keep the password from being revealed.

Rather than drone on and on I’ll stop there. I may be missing a big part of the picture.
Hopefully some helpful soul will be able to go from there and push me toward understanding the connections between these things and how to make them all talk.

(Should add that I have tried w/ Firewall down to no avail. Understand there can be router issues but this is a NetGear WNDR3700 and works great in all respects. I have changed the DNS settings in the router according to StrongVPN help text. PC otherwise still working normally so the DNS change didn’t seem to have upset anything.)

I think You need to check which VPN technology the “host” is using. Whether it’s pptp or openvpn or something else and use NetworkManager to configure the one they are using.

Looking at the logs of NetworkManager will help You determine what is actually wrong. This command should be helpful :

tail -f /var/log/NetworkManager

After running this command try to connect using the applet and look at the logs.

One more remark is that there were lots of bugs with knetworkmanager and openvpn (possibly pptp and others as well but I only tried openvpn myself). All the bugs that I have encountered are fixed in plasmoid networkmanagement in KDE 4.7 and openSUSE 11.3 is using older KDE version so You might be affected by some of those bugs.

Best regards,