Help to install a dual system.

I got my new Hp envy 15. It comes with core i7 and win7. I tried to install opensuse 11.3 next to windows. I need both systems. When installing I got the message that the windows partitions cannot be resized and should be deleted. The actual message is: Resize impossible due to inconsistent fs. Try checking fs under windows. I already checked the disk under windows and the problem persist.
I’ll appreciate your help.

I would recommend running partition commander or something similar first.
Then you should have an available partition. Linux code for NTFS isn’t
100% and that is what it is trying to tell you. (Not too well, tho…)

You probably already have the maximum 4 Primary partitions in use. My guess WIN7 was pre-installed and has a load of unnecessary garbage partitioning.

A live CD of any Linux distro, or Parted Magic can get us

fdisk -l

That will tell us what we need to know

I checked my disk in Win7 and indeed there are four primary partitions. They are: System (NTFS), Recovery (NTFS), C:/ (NTFS), and HP_Tools (FAT32).

I downloaded parted magic. What should I do with it? I’m a newbie in this matter :). I used OpenSuse since one year but I’m a visual designer and don’t have much experience dealing with these kind of programs.

My machine description: HP Envy 15. Intel core i7 Q720 @ 1.60 Hz 1.60 Hz. 6GB. Win7 home premium.

Thanks

Using Parted Magic an Introduction

I tried the parted magic and I couldn’t go far. After the first screen, I got the following message: It seems the media that contains thepmagic-5.0.sqrs cound not be found. Help us out bt trying to mount the device that contains the Parted magic media manually and report the result to the forum. This initramfs contains a very limited busybox built.

I tried the example it gave me: mount dev/sr0 /mnt. But it didn’t work out. I also tried a live cd distro. The result was similar it coundn’t find the media where the installer was.

I have the parted magic in a Cd-rom. My DVD unit is external and plug through USB.

This problem with Parted Magic was solved. On the HP envy 15 it is needed to connect the DVD drive to the eSata/USB port in order to run the installation of a live linux distro.

I found this: This stalled the installation until I decided to connect the external USB 2.0 dribve to the eSATA/USB 2.0 port. After that installer found the DVD drive just fine. This indicates the installer kernel is missing xhci driver. It may be possible to load the xhci driver manually but workaround of connecting to the USB 2.0 port was easier :slight_smile: I did have trouble with installer finding the DVD drive even when it was connected to eSATA/USB 2.0 port unless I booted installer with “askmethod” parameter. I did not run enough tests to verify that I did not have another problem (like just a loose cable). In any case, if you connect the DVD drive to eSATA/USB 2.0 port and installer still fails to find the drive, just boot with “askmethod” parameter. Source: Installing Fedora 13 on HP Envy 15 | hp + community and regional Linux distributions.

I’ll need some hints about what I have to do in Parted Magic with my disk? If there are already four primary partitions how can I install OpenSuse on my computer next to Win7.

If there are already four primary partitions how can I install OpenSuse on my computer next to Win7
To be honest it’s not something I would recommend, especially to someone with limited knowledge.
To do it, you need to delete at least one Partition and which one will depend how they are laid out, but one next to your largest partition (the so called C drive). Then you can shrink C to make some free space to add to the section where you deleted the partition. Then make ONE large Extended Partition in all that free space.

I have to get a 16GB USB to create a recovery disk for my Hp. This will in any moment reinstall everything as it comes from the factory. Then I’ll be able to remove the recovery partition. According to Hp forums and official help this is a safe way.

So you want to install openSUSE in a 16GB partition.
Is the recovery Partition next to the C partition? Then you could shrink at least a little off C and expand the 16GB space in to it.

But until I see a reliable piece of disk info as requested, I can’t be sure of advising you. Except to say - you may live to regret it - Why?; Because if you can’t figure this bit out for yourself, there ain’t a hope you will if it all goes belly up.

Hi here my disk how it is right now.

http://pktweb.com/drnn1076/personal/myDisk.PNG

My idea is actually to delete the recovery partition after the recovery disk is made. And then to create a large partition to my OpenSuse installation.

I hope the disk image might help.

So you could do that and shrink the C drive to make more free space
Imageshack - mydisk.png

Hi again,
I did my recovery disk in a usb. I shrunk the c drive and left 226 Gb of space for opensuse.
Everything went OK. Suse recognized the new partition. However, in the installation summary the following message appeared:
The bootloader is installed on a partition that does not lie entirely below 128GB. The system might not boot.

Partitioning
Create extended partition /dev/sda4 (226.45 GB)
Create swap volume /dev/sda5 (2.01 GB)
Create root volume /dev/sda6 (20.00 GB) with ext4
Create volume /dev/sda7 (204.46) for /home with ext4
Set mount point of /dev/sda1 to /windows/C
Set mount point of /dev/sda2 to /windows/D
Set mount point of /dev/sda3 to /windows/E

Booting
The bootloader is installed on a partition that does not lie entirely below 128GB. The system might not boot.
Boot Loader Type: GRUB
Status Location /dev/sda4 (extended).
Change Location:

  • Boot from MBR is disabled (enable)
  • Boot from “/” partition is disabled (enable)
    Sections:
  • openSUSE 11.3 (default)
  • windows 1
  • windows 2
  • Failsafa – openSUSE 11.3
  • Hard Disk

Thanks for your help.

It may or may not work
What you have there looks OK. But because the partition is a long way from the start of the drive. (Imagine if I was telling you what to do and I was stood right next to you, OK - yes. But if I were half a mile away you might not hear me…

Try it. Install, it will sort of reboot, but not properly, so once you get to the desktop for the first time, reboot proper and see if it boots. If not, just re-run the install and click this: - Boot from MBR is disabled (enable)

HI. It worked without re-running and reinstalling!

Right now I’m installing software and testing everything, sound, DVD, network, etc. So far the synaptics are kind of annoying. Anyway I’m happy.

Thank you very much for your help caf4926.

http://www.pktweb.com/drnn1076/personal/drnn-suse.png

drnn1076

Excellent news.
Well done!

This sounds like the issue I have. I would be cool, since this is an extremely common HP setup, if there where some sort of warning, or maybe even a more explicit warning message?

Do you mean you have too many primary partitions already?
That problem is from your pre-installed windows system and is well reported on