Help! Stuck at keyring on boot.

I am running OpenSUSE Leap, and typically boot into the standard desktop environment then work mostly in a terminal (qterm) and browser. Starting a couple of days ago, when I first boot I get to a mostly blank GUI screen with the window to enter the keyring password, but after entering and clicking “unlock”, the computer just hangs, and I am unable to do anything from the graphical interface.

I switch over to a shell (Ctrl-Alt-F1) and reboot or shutdown with the shutdown command, but nothing seems to get me to a point where I can make use of the GUI.

I have tried to search for this issue online but have not had any luck. I need some help on where to look, what to try, etc, before I give up and just wipe the system and reinstall new.

Which “standard desktop environment” is that? Is it KDE, or Gnome, or LXQt, or …

We are not good at reading minds.

Also, what’s your graphics card? We sometimes see problems for people with Nvidia graphics or AMD graphics – usually after a kernel update. There should be a boot option to boot the previous kernel, and you might try that.

As I said, I don’t really use the desktop environment, except to launch a terminal and a browser, so I don’t really pay much attention to those details. I expect it should be whatever is the default used for Leap 42.3.

I am using a different machine for now until I can get that other problem resolved, so I don’t have other details readily available. The problem is on a Dell 5430u, and original specs can be found at

The default install for 42.3 is KDE, with “sddm” as the displaymanager (handles login).

The spec sheet that you linked seems to show Intel graphics. We usually don’t see the problems that you are describing with Intel graphics.

Have you tried booting to the previous kernel?

On the grub boot menu, there should be a choice for “Advanced options”. And, if you select that, the next screen should allow you to choose a kernel. The first choice will be the current kernel. The next choice (possibly 2 lines down) should be the previous kernel.

Perhaps a re-install might be the quickest way for you to get things going again. If you do that, I would suggest installing Leap 15.0.

Two things I would try before reinstalling, if nrickert’s other suggestions don’t help. Even though no one would expect a video issue to trigger a password window inopportunely timed, bugs can cause strange problems:

1-uninstall xf86-video-intel. That will trigger use of the X server’s integrated modesetting driver. Alternatively, explicitly specify the modesetting driver via /etc/X11/xorg.conf.d/50-device.conf. (Last official upstream update of xf86-video-intel was over 4 years ago.)

2-Disable plymouth: append plymouth.enable=0 (via the e key in the grub menu) to the kernel cmdline. This will change various init timings.

This won’t make a substantive change, but may cause a useful error message to become apparent during init: remove splash=silent (via the e key in the grub menu) from the kernel cmdline.

Keyring is normally triggered by NetworkManager starting but other programs may require it. Also adding Skype can cause the Gnome keyring to trigger in KDE. So we need a bit more info about your setup. If it is the KDE keyring then you can simple set a blank password and it no longer asks. Gnome keyring is a bit more tricky.

Seeing this since a couple of days on Tumbleweed. I uninstalled the keyring packages and locked them, which works around the issue, but I have not been able to find out which package recommends ( that is what must happen ) the keyring install. JFYI,

There are two KWallet and Gnome Keyring, Kwallet is used by KDE programs that require a password(s) and Gnome Keyring is used by gnome based programs, like Skype