Help setting wireless usb adapter...

Hi to all…
I’m novice with linux and I want again your help.
After had installed opensuse 11.3 with your help now I want your help about setting a usb stick and connecting to internet.
I can connect with ethernet but as I want to have also wireless internet I bought a LEVELONE WUA-0605 wireless usb adapter witch I can’t setup and connect…
The only data witch I was able to find are:

linux-0wi7:~ # hwinfo --wlan
21: USB 00.0: 0282 WLAN controller
[Created at usb.122]
Unique ID: 2UT6.NomXlQ88uo3
Parent ID: k4bc.9T1GDCLyFd9
SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0
SysFS BusID: 1-3:1.0
Hardware Class: network
Model: “Realtek RTL8191S WLAN Adapter”
Hotplug: USB
Vendor: usb 0x0bda “Realtek Semiconductor Corp.”
Device: usb 0x8172 “RTL8191S WLAN Adapter”
Revision: “2.00”
Serial ID: “00e04c000001”
Driver: “rtl819xU”
Driver Modules: “r8192s_usb”
Device File: wlan0
Features: WLAN
Speed: 480 Mbps
HW Address: 00:11:6b:47:de:ed
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
WLAN bitrates: 1 2 5.5 11 6 9 12 18 24 36 48 54
WLAN encryption modes: TKIP CCMP
WLAN authentication modes: open wpa-psk wpa-eap
Module Alias: “usb:v0BDAp8172d0200dc00dsc00dp00icFFiscFFipFF”
Driver Info #0:
Driver Status: r8192s_usb is active
Driver Activation Cmd: “modprobe r8192s_usb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #16 (Hub)

also…

linux-0wi7:~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g Mode:Managed Access Point: Not-Associated
Bit Rate:0 kb/s
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

another problem is that I can’t found network manager. I activate with Yast but I can’t see nothing on system tray…>:(

another problem is that I can’t found network manager. I activate with Yast but I can’t see nothing on system tray…

Start YaST / Network Devices / Network Settings / Global Options Tab set the bullet for “User Controlled with NetworkManager” and this will give you the icon that you seek. Many go ahead and try to use the ifup setting first, which requires you to manually enter your wlan setup, but it does not hurt to try NetworkManager. I would look through all of the screens before setting anything as you can identify for sure what the names of the interface(s) have been set for.

Thank You,

I set the bullet for “User Controlled with NetworkManager” but I cannot see the icon of NetworkManager…
Any idea?How can setup wlan with ifup?

Try running this command in terminal :

knetworkmanager

And tell us if You’re able to see the icon.

Best regards,
Greg

Assuming the OP is using KDE?!

something is running in terminal I dont know what but is “huge”…:slight_smile:

the last lines are:

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QSystemTrayIcon::setVisible: No Icon set
QLayout: Attempting to add QLayout “” to InterfaceConnectionItem “”, which already has a layout
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
<unknown program name>(10406)/ KStartupInfo::createNewStartupId: creating: “linux-0wi7;1293209365;473413;10406_TIME0” : “unnamed app”
kbuildsycoca4 running…

a message appearing:

Another NetworkManager client is already running. Use KNetworkManager in future?

Don’t run it at all cause You’re apparently using some other client. What desktop environment are You using ?

opensuse 11.3 with KDE

Hmm that’s strange. Could You post the output of this command here ? :

rpm -qa '*Network*'

Best regards,
Greg

NetworkManager-pptp-0.8-3.1.i586
NetworkManager-pptp-kde4-0.9.svn1057339-4.1.i586
NetworkManager-vpnc-kde4-0.9.svn1057339-4.1.i586
NetworkManager-openvpn-0.8-3.1.i586
NetworkManager-kde4-0.9.svn1057339-4.1.i586
NetworkManager-kde4-lang-0.9.svn1057339-4.1.noarch
NetworkManager-vpnc-0.8-3.1.i586
NetworkManager-openvpn-kde4-0.9.svn1057339-4.1.i586
NetworkManager-glib-0.8-8.2.1.i586
NetworkManager-kde4-libs-0.9.svn1057339-4.1.i586
NetworkManager-0.8-8.2.1.i586

Any help???:’(:’(:’(:’(:

So did you answer the ? with Yes? and reboot?


Some are using the Plasma widget so you could
Open a terminal
Try this as su -

zypper in plasmoid-networkmanagement

Accept removal of knetworkmanager

Then add the plasma network widget to the panel

When using KDE, you must activate the NetworkManager in YaST as I suggest in my first message. In addition, you must load KWallet to keep track of your network passwords. Sometime one or both of these applications can have messed up configurations. One way to solve that is to remove them and start over. I have a script file that can do that for you. One warning though, it removes any previous entries for KWallet and so, if you have other passwords stored in it, you need to get them out before using this procedure.

knetfix - Version 1.00 -KDE KNetworkManager Fix for Wireless Connection Problems

Thank You,

So did you answer the ? with Yes? and reboot?

yes I did but nothing

I did not use Kwallet and I haven’t stored passwords…

On 12/27/2010 06:06 PM, dalikman wrote:
>
> I did not use Kwallet and I haven’t stored passwords…

In that case, NetworkManager will not work.