Help running mysql!

For some reason, I can’t seem to run mysql (according to YAST it’s already installed). When i run the commands below I get the errors:

/usr/sbin/mysqld

090609 15:39:20 [Warning] Can’t create test file /var/lib/mysql/linux-9xe6.lower-test
090609 15:39:20 [Warning] Can’t create test file /var/lib/mysql/linux-9xe6.lower-test
090609 15:39:20 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: ‘create’.
InnoDB: Cannot continue operation.

/usr/sbin/mysqld --tmpdir=/home/mycomp/mysqltmpdir

090609 15:39:20 [Warning] Can’t create test file /var/lib/mysql/linux-9xe6.lower-test
090609 15:39:20 [Warning] Can’t create test file /var/lib/mysql/linux-9xe6.lower-test
090609 15:39:20 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: ‘create’.
InnoDB: Cannot continue operation.

/usr/sbin/mysqlmanager

090609 15:24:16 [WARNING] can’t open password file /etc/mysqlmanager.passwd: errno=2, No such file or directory
090609 15:24:16 IM pid file: ‘/var/lib/mysql/mysqlmanager.pid’; PID: 8788.
090609 15:24:16 can’t create pid file /var/lib/mysql/mysqlmanager.pid: errno=13, Permission denied

sudo /usr/sbin/mysqlmanager

090609 15:24:31 You are running mysqlmanager as root! This might introduce security problems. It is safer to use --user option istead.

090609 15:24:31 [WARNING] can’t open password file /etc/mysqlmanager.passwd: errno=2, No such file or directory
090609 15:24:31 IM pid file: ‘/var/lib/mysql/mysqlmanager.pid’; PID: 8792.
090609 15:24:31 accepting connections on ip socket (port: 2273)
090609 15:24:31 guardian: starting instance ‘mysqld’…
090609 15:24:31 starting instance ‘mysqld’…
090609 15:24:31 accepting connections on unix socket ‘/tmp/mysqlmanager.sock’
090609 15:24:31 [ERROR] Fatal error: Please read “Security” section of the manual to find out how to run mysqld as root!

090609 15:24:31 [ERROR] Aborting

090609 15:24:31 [Note] /usr/sbin/mysqld: Shutdown complete

Use the runlevel scripts to start the daemon (as root)

/etc/init.d/mysql start

or shorter

rcmysql start

Or got to YaST>System>System Services and enable mysqld there.

That’s how I can produce the error: disabling Mysql in Yast and then trying what poster did. So it must be that the service is not enabled. Don’t know where that is set exactly.