Help Resolving External IP to Internal IP

Hi guys,

I’m using openSUSE11.1 on my box. I’ve got my NetComm router port forwarding 2871 to web server. Sadly, when I try to access my internal IP, it just brings up the login page for my router.

My box:
10.1.1.234
Apache listens on port 80

Router:
10.1.1.254
Port forwards 2871 to 10.1.1.234:80

External IP
60.242.91.36

I’ve tried accessing 60.242.91.36:2871 and it just says page not found.

I’m told I might be able to edit my /etc/hosts file to help with this? I tried to, but no success. This is how my hosts file looks.

127.0.0.1 linux localhost.localdomain localhost

127.0.0.1 localhost

60.242.91.36 localhost

special IPv6 addresses

::1 localhost ipv6-localhost ipv6-loopback

fe00::0 ipv6-localnet

ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts

127.0.0.2 linux-d3vb.site linux-d3vb

Any suggestions please?

Jace

Nevermind, seems like what I really want is NAT. I’m not going to go do that, so I’ll just deal with it.

Yes.
Also, make sure that your router configuration can not be accessed from the external interface. It is risky. (There must be some setting for this).