help resolve wifi issue with Broadcom BCM4352 14e4:43b1, OpenSuse 13.1

My laptop is an Asus G75VX with a Broadcom BCM4352 wireless network adapter. I just installed OpenSuse 13.1 and cannot get wireless to work.

I tried Larry Finger’s instructions here, https://forums.opensuse.org/english/get-technical-help-here/wireless/484106-broadcom-firmware-needed-b43-but-i-have-no-network-easierwork-around.html, but no results.

I used Yast to look for info on my hardware:
No “Wireless LAN” listing found, so no “kernel driver” line was found either.
But this was found under the listing for Network Card:

Broadcom Network Controller
Device identifier (spec): 74019
Device identifier: 82865

Then I used “dmesg | grep firmware” in the command line and got no output at all.

Using “/sbin/lspci” in command line I got this:
03:00.0 Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)

and using “/sbin/lspci -n” I got:
03:00.0 0280: 14e4:43b1 (rev 03)

Looking at the kernel output with the command “dmesg | less”, I got these snipets, but nothing tells me anything about firmware:

1.309573] pci 0000:03:00.0: [14e4:43b1] type 00 class 0x028000
1.309599] pci 0000:03:00.0: reg 0x10: [mem 0xf5400000-0xf5407fff 64bit]
1.309620] pci 0000:03:00.0: reg 0x18: [mem 0xf5200000-0xf53fffff 64bit]
1.309728] pci 0000:03:00.0: supports D1 D2
1.309729] pci 0000:03:00.0: PME# supported from D0 D1 D2 D3hot D3cold
1.309772] pci 0000:03:00.0: System wakeup disabled by ACPI

2.452664] usb 1-1.1: New USB device found, idVendor=13d3, idProduct=3404
2.452666] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
2.452668] usb 1-1.1: Product: BCM20702A0
2.452670] usb 1-1.1: Manufacturer: Broadcom Corp
2.452671] usb 1-1.1: SerialNumber: 6C71D94968E8

When I ran “/usr/sbin/iwconfig”, I got:

lo no wireless extensions.

enp4s0 no wireless extensions.

I then checked the log at /var/log/boot.log and there was no mention of any firmware or any mention of my BCM4352. I then used Yast to access the system log messages and these are all the lines that had anything to do with firmware:

COMMAND=bcm43xx_firmware/install_bcm43xx_firmware_no_net [from when I followed Larry’s instructions]
2013-11-22T22:22:14.058182-05:00 linux-htt8 kernel: 0.187976] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

Still no wifi.

So I went to packman.links2linux.de/package/broadcom-wl/443340 and downloaded/installed broadcom-wl-kmp-default-6.30.223.141_k3.11.6_4-2.6.x86_64.rpm
Then I rebooted; no results

Don’t know what to do now. I am fairly new to Linux and command lines, so please be patient with me :slight_smile:

Best,
Jeremy

Are you sure you use kernel-default? Normally kernel-desktop is installed.
Please post the output of:

uname -a

Here is the output of uname -a:

Linux linux-htt8.site 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux

Right, as suspected.
So you have to install the package broadcom-wl-kmp-desktop !
http://packman.links2linux.de/download/broadcom-wl/1568712/broadcom-wl-kmp-desktop-6.30.223.141_k3.11.6_4-2.6.x86_64.rpm

And you can remove broadcom-wl-kmp-default again, you won’t need it. (and kernel-default as well if it is installed)

Don´t forget:
http://packman.links2linux.de/download/broadcom-wl/1568714/broadcom-wl-6.30.223.141-2.6.x86_64.rpm

Here is the blacklist file for the Kernel Modules.

Right, the package broadcom-wl is needed as well.
I thought he wrote he installed that already, together with the incorrect broadcom-wl-kmp-default.
That’s what you get when you reply to a few threads about wifi issues simultanously… :shame:

silly question, I know - using the command line how do i remove the files that were installed by broadcom-wl-kmp-default and kernel-default?

partially answered my own question. I used

sudo zypper remove broadcom-wl-kmp-default

to uninstall broadcom-wl-kmp-default

which gave me this output, which I assume is correct


(1/1) Removing broadcom-wl-kmp-default-6.30.223.141_k3.11.6_4-2.6 ..............................................[done]

wolfi323, regarding kernal-default, is that the full name of the other package i need to remove, if not, what is the full package name for kernel-default?

Either:

sudo zypper rm broadcom-wl-kmp-default kernel-default

or:

sudo rpm -e broadcom-wl-kmp-default kernel-default

Yes.

wolfi323, regarding kernal-default, is that the full name of the other package i need to remove, if not, what is the full package name for kernel-default?

kernel-default is the full package name.

Thanks for all the help!

I installed the suggested packman packages, rebooted, and now my wifi seems to be working correctly lol!

Is it necessary that I still remove kernel-default? How is related to wifi?

Thanks

It’s not strictly necessary, and not directly related to wifi as well.

But it takes unnecessary space on your hard disk. And it could take longer to install updates.
And if you would boot it (you can select it in “Advanced Options” in the boot menu), wifi would not work, since you don’t have the corresponding driver installed now.

And it’s (nearly) exactly the same as the kernel-desktop anyway.

That makes sense. Thanks for explaining.

I appreciate everyone’s help here. Now on to my next task - regaining control over LCD brightness.