Help required with Firefox and Java!!!

Hi,

I recently migrated from OpenSuse 11.2 to 11.3 after doing a fresh install. I have both Firefox as well as Java installed on my system, however, Firefox fails to recognize Java.
http://i33.tinypic.com/alp8oo.jpg

I cannot see it in the Plugins list but I know Java has been installed successfully.
http://i33.tinypic.com/2mw7ck6.jpg

Moreover, I have followed the instructions mentioned at:
How do I download and install Java for my Linux computer ?
but I was unsuccessful.

I have followed the instructions at:
SDB:Installing Sun’s Java on openSUSE - openSUSE
to create a symbolic link, but it still doesn’t work.

This is so frustrating… I was able to get Java working with Firefox on 11.2 but something is going wrong when I am trying to get it working with 11.3!
>:(

Follow this
Installing 32-bit Java the Yast way

32 or 64 it’s basically the same principle

If you are runing a 64 bit system you’ll have to install the 32 bit JRE to get "java applets and java web start"as it’s say on the sun’s web site

Actually, I’m going to have to update that (I completely forgot I wrote those :shame:). So far, in my experience, using 32-bit and 64-bit, 100% of the time it’s worked just by installing java-x_x_x-sun and java-x_x_x-sun-plugin.

Good information to know. I know I ran into this problem as well when trying to load a upnp program that needed java when it was only 32-bit, so I had to install the 32-bit java.

Hi, I have followed the procedure mentioned by the poster where he explains about installing two updates via Yast. One is ‘java-1_6_0-sun’ which is the the Java Runtime Environment (JRE) and the other is ‘java-1_6_0-sun-plugin’ which I believe is the equivalent browser plugin. The poster mentions about searching for ‘sun’ in Yast inorder to install the mentioned updates. However, as you must be knowing, Java is no longer maintained by Sun and therefore the search naturally does not yield any results.

As I have mentioned before, I have installed the JRE as can be seen in the screenshot below:
http://i37.tinypic.com/2ljmjrq.jpg

However, I was not able to find the equivalent Java plugin component for Firefox. I did search with different keywords like ‘plugin’, ‘plugins’, ‘java’, ‘jre’, ‘firefox’, etc, but no success.

Additionally, the poster also mentions about creating a symbolic path by executing the command

ln -s /etc/alternatives/jre_1.6.0/plugin/i386/ns7/libjavaplugin_oji.so

But in my case, libjavaplugin_oji.so is at the following location and therefore the above mentioned symbolic path cannot be used.

/usr/java/jre1.6.0_21/plugin/i386/ns7/

http://i33.tinypic.com/2af7mb.jpg

Can you think of any other suggestion that I can try?

Perhaps you should post terminal result of:

zypper lr -d

Sure… Here is the result:-

ash@linux-up5o:~> zypper lr -d 
# | Alias                | Name                  | Enabled | Refresh | Priority | Type   | URI                                                             | Service
--+----------------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
1 | Libdvdcss repository | Libdvdcss repository  | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                            |        
2 | Packman Repository   | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/11.3/                              |        
3 | repo-debug           | openSUSE-11.3-Debug   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
4 | repo-non-oss         | openSUSE-11.3-Non-Oss | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
5 | repo-oss             | openSUSE-11.3-Oss     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
6 | repo-source          | openSUSE-11.3-Source  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |        
7 | repo-update          | openSUSE-11.3-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                       |        

I have also posted in a separate thread about the errors that I get while running Yast:-
http://forums.opensuse.org/english/get-help-here/applications/443597-something-wrong-yast.html
I am not sure, but maybe these two issues could be related to each other…

View by repository and select NON-OSS
You will see Sun Java in there:
ImageBam - Fast, Free Image Hosting and Photo Sharing
Just select NON-OSS rather than System as in the image

Unfortunately, I am not able to select NON-OSS… Its not listed in Yast!
Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting

In another thread you are reporting trouble accessing some repos, this one I think. So it’s obviously not loading. I pointed you to mirrors, did you try one?

I have never tried adding repositories, so I am new to this process… As I have mentioned in that thread, could you please be a bit more elaborate since I am facing difficulties adding URL to Yast.

You are missing the OSS and the NON-OSS in the pic you posted earlier.

Go in to Yast - Software - Repositories and Disable and turn off refresh on those 2 repos. (#4 and 5)

I see you are in India. I think all mirrors are quite some way from you.

But try adding these:

NON-OSS
Index of /pub/opensuse/distribution/11.3/repo/non-oss

OSS
Index of /pub/opensuse/distribution/11.3/repo/oss

Here is a repo guide
Repository Management

Yeah, exactly… both the OSS and NON-OSS repositories are missing… :frowning:

I will try and disable/turn off refresh on those two repos.

By the way, I am not in India but in UK. I study at the University of Salford in Greater Manchester and therefore I thought the closest mirror to me would be Centre for Scientific Computing, University of Warwick… Accordingly, I tried to add the URL, but I believe I must have done it in the wrong way.

Nevermind, I will add the repos you have listed above and get back to you with my observations.

NO
Those repos are miles away.

You want these:NON-OSS
UK Mirror Service: sites/download.opensuse.org/distribution/11.3/repo/non-oss

OSS
UK Mirror Service: sites/download.opensuse.org/distribution/11.3/repo/oss

I have to sleep now
See you on the other side. 3am for me :wink:

OK… will try the UK mirrors and get back to you tomorrow.

Thank you for your help today… :slight_smile:

Hi, I’m back with my observations and very happy to say that things did work after adding mirrors for the OSS and NON-OSS repos. Now I am able to see the Java plugin in my firefox browser… :slight_smile:

So finally, the issue was related to Yast not being able to access the OSS and NON-OSS repositories… Wow, took me some time to figure that out!

And finally, I would like to thank all the community members who contributed towards solving my problem especially caf4926… You guys simply rock!!! :good:

No problem mate.
Thanks for filling us in on things.