Help req'd with broken upgrade Leap 42.2 to 42.3, boot-repair info.

Hello, I’m hoping someone can help me with a broken upgrade from Leap 42.2 to 42.3.

As Leap 42.2 was EOL with no more updates I tried an upgrade using a DVD of 42.3. Unfortunately it didn’t go to plan. I think the main problem is that /dev/sda has the existing /home and /dev/sdb has the operating system.

I then tried a clean install overwriting the os still keeping the existing /home, I had to change the partitioning as it wanted to overwrite the /home partition with the os partitions.

I then tried boot-repair but that failed with an error message:-

Please enable a repository containing the [grub-efi-amd64-signed] packages in the software sources of openSUSE 42.3 (sdb3)

So I’m now stuck. Could someone have a look at the boot-repair info on the link at the top and give me some help?

I did start going through
and got as far as efibootmgr -v which seems to have an entry for the root partition but I’m not sure the info for that entry is correct.

Please ignore, now sorted.