Help reading an inaccessible cdrw created in Kb3

This is probably a futile stab in the dark but I’m ready to try anything to save many hours of rekeying. Before upgrading to 11.2 I dutifully made backups of important files and burned them to cdrw using Kb3. After creating them I checked to be sure that the files were on the disc but I did not remount the disc before doing so. When I tried to restore them,after upgrading, the disc was not recognized by the operating system. Kb3 recognized it as a data project but I could not access the individual files. I tried to access the cd as root without success. The drive is working and I was able to access an earlier backup. I recall a message regarding a missing md5 checksum but I am unsure if that pertains to this problem. Any ideas how to recover the data or even what I did wrong so I can avoid this problem in the future would be appreciated. Thank you

Hopefully it may be just a simple problem with mounting and reading the CD. Try these commands and report back.

isoinfo -i /dev/sr0 -d
isoinfo -i /dev/sr0 -l -R

That’s a letter ell, not numeral one in that last command.

Dear ken_yap

Thank you from the bottom of my heart. You saved me hours rekeying!
I was able to find all of the files with isoinfo, mounted /dev/sr0 to /mnt, and was able to access them. Thanks again.