Help please with MX1000 mouse config

I recently added a Logitech MX1000 mouse. I’m unable to get it configured properly. I have searched these forums and Googled for two weeks. I’ve tried just about every howto that I could find and still I’m missing something. Can someone help?

Here is a section of my xorg.conf:

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “ButtonMapping” “1 2 3 6 7”
Option “Buttons” “10”
Option “Device” “/dev/input/mice”
Option “InputFashion” “Mouse”
Option “Name” “Logitech;MX1000”
Option “Protocol” “explorerps/2”
Option “Resolution” “800”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

cat /proc/bus/input/devices gives me this:

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name=“AT Translated Set 2 keyboard”
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
U: Uniq=
H: Handlers=kbd event0
B: EV=120013
B: KEY=402000000 3802078f840d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name=“PC Speaker”
P: Phys=isa0061/input0
S: Sysfs=/class/input/input1
U: Uniq=
H: Handlers=kbd event1
B: EV=40001
B: SND=6

I: Bus=0019 Vendor=0000 Product=0002 Version=0000
N: Name=“Power Button (FF)”
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/class/input/input2
U: Uniq=
H: Handlers=kbd event2
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name=“Power Button (CM)”
P: Phys=PNP0C0C/button/input0
S: Sysfs=/class/input/input3
U: Uniq=
H: Handlers=kbd event3
B: EV=3
B: KEY=10000000000000 0

I: Bus=0003 Vendor=046d Product=c50e Version=0111
N: Name=“Logitech USB Receiver”
P: Phys=usb-0000:00:13.0-2/input0
S: Sysfs=/class/input/input8
U: Uniq=
H: Handlers=mouse0 event4
B: EV=20007
B: KEY=ffff0000 0 0 0 0
B: REL=143
B: LED=ff00

lomoco -i gives me this:

001.011: 046d:c50e Receiver for MX1000 Laser (C-BN34) Caps: CSR SMS
Receiver type: C50E
Mouse type: MX1000 Laser Cordless Mouse
Connect button on mouse pressed: no
Active RF Channel: 1
Battery status: 3 (low)
Cordless security ID: 0x0000
Receiver talking: yes
Lock Request (CONNECT button pressed): no
Mouse Powerup (First time out of the box auto-locking): no
Receiver Unlocked (Mouse disconnected): no
Wait Lock (Searching for mouse): no
Device physical shape type: 0
SmartScroll (SMS): on
USB Mouse Polling Interval: 10ms

ls /dev/input gives me this:

by-id by-path event0 event1 event2 event3 event4 mice mouse0

There are several things I don’t understand, one of them is the button mapping. On the my mx1000, buttons 1, 2, 3, easy. 4 and 5 are the scroll wheel after that I’m not sure. Right now the “arrow” thumb buttons work as forward and backward in Firefox and the middle thumb button works as middle click (ie button 2 - open a link in a new tab). In Konqueror, the arrow thumb buttons work as left/right scroll.

Can someone give me some insight?

I’d try out the “evdev” driver instead of the standard “mouse” driver - see your xorg.conf!
I have a Logitech LX5 mouse - indeed, it’s not that advanced as the MX1000, but I got at least the wheel side tilt working using this driver. Not without tinkering, but the “evdev” driver has in general much better configuration options as the driver you’re using currently. As a recommendation, create a udev rule for your mouse to ensure it gets properly recognized. Otherwise you’ll get problems if you attach the receiver to another USB port.

Hope that helps!

Whoa, slow down… :slight_smile:

I have 64bit 10.3 installed here. I’m far from an expert but I can funble my way around ok. Am I correct that evdev is included during the the OS install? I’ve tried changing the driver in the xorg.conf to"evdev" and saw no success there. I figured I was missing something else.

For instance, in xorg.conf there is a “mouse[1]” and in cat /proc/bus/input/devices under “H: Handlers=mouse0” I suppose these need to match, right? Do I change xorg.conf to match?

I have no idea how to creat the udev rule. Can you point my to a link that has some info on this?


rhorstkoetter > How to proceed to establish such an udev rule ?

The “evdev” driver is part of Xorg, yes.
I’m sorry, but I cannot provide a detailed howto for configuring this mouse setup - it was back in SUSE 10.1 when I did this. What I know is that the “evdev” driver is the appropriate thing to look for and creating a udev rule is valuable due to the fact that device naming could change e.g. if you attach the mouse to another USB port - then the Xorg config does not apply anymore. From what I remember, you have to put udev rules in /etc/udev/rules.d/. The entries are proceeded in lexical order and need to have a *.rules postfix. Just have a look on that directory and you’ll find out how to do this. I apologize, but I remember it was much tinkering, but finally everything worked great. The udev rule basically ensures that the mouse is identified on the basis of its usb-id and an according device node, e.g. /dev/input/event0 (this one have to be referenced in Xorg config) is created once detected, regardless of the usb bus the mouse is attached to. The rule therefore identifies the mouse and link to the appropriate device-node defined. After searching around a bit I found this Archlinux wiki page, there you should find the appropriate information how to configure the buttons and the “evdev” driver in Xorg ArchWiki :: MX1000 Buttons - ArchWiki
The udev rule would be an addition to that. I’m pretty sure, you’ll find a detailed decription how to do so on the internet.

I’d love to give more detailed instructions, but this is what I remember spontaneously. I hope it’ll help you to work out the issue!

Thanks rhorstkoetter, in all my searching I had not found that wiki. I will give it a try as soon as I can figure out which opensuse 10.3 repo has xvkdb and xbindkeys - anyone got a clue on that one?

And also thanks for the heads up on the udev rule. Looks like I have some more reading to do.

Don’t know if this will help, but here’s what I used to use for an MX1000 in 10.1 to 10.3 -

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “7”
Option “Device” “/dev/input/mice”
Option “Name” “ImExPS/2 Logitech Explorer Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
Option “ButtonMapping” “1 2 3 6 7”